Highlighted
Absent Member.
Absent Member.
646 views

LR 9.51 loadrunner patch issues

Is anybody having similar issues after installing LR 9.51 patch ontop of 9.50?

1 - Transactions come back with a negative response time

2 - full analysis fails to compile where transaction rate is very high for a test (1200 tps over a 1 hour test, for example).

Thanks
Brian
6 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: LR 9.51 loadrunner patch issues

We haven't seen customer's facing this problem.

Is this always reproducible? If yes, give me the steps for the same.

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LR 9.51 loadrunner patch issues

I'm not sure if it's reproducable with any script whatsoever, but I have noticed that the cause in this case is related to having a sub 1 second think time. In the script, I have think time set to 0.5 seconds. It's worked fine on LR 9.5 and 9.0, but it's not working now.
When running a test, you'll notice min response time is negative, and when generating analysis, you get a log full of the following types of error:
75005 Transaction : InstanceID: 77309411713 VUser info:Host:[removed by me], Group:ADS_VAC_ValidAdCall_v03, Script:ADS_VAC_ValidAdCall_v03, ID:17 - Negative response time : R:-0.0514426231384 T:0 W:0.0000100136
0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: LR 9.51 loadrunner patch issues

I tried playing with this, but didn't observe any weird behavior. Everything seems Ok. Were you running he scripts created in older versions of LoadRunner?

Thanks
KM
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LR 9.51 loadrunner patch issues

Hi,
I have the same problem with a script based on Oracle 2 Tiers protocol.

When i run this script in Controller, the firsts transactions end with negatives responses times. During the test the responses times is low but no negative.

My version of Loadrunner is 9.52

I have no think tim under 1 sec.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LR 9.51 loadrunner patch issues

We resolved our issue a while ago, sorry for not posting the solution. Our issue was a little different in that response times were fine after a reboot, but would degrade to negative after some time. The problem was a combination of Windows and the AMD Quiet'n'Cool chip feature. If you're not using an AMD chip in your servers, I'd look further with support.

Here's the microsoft article.
http://support.microsoft.com/kb/895980

Brian
0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: LR 9.51 loadrunner patch issues

I also gort negative response time for my test. I am using HP PC 11.52 and whatever option is suggested above (microsoft link) is only application for MS 2003 server not for MS 2008 server.

 

Please advice how to resolve issue on MS 2008.

 

Will rebooting work everytime?

 

Regards,
Gagandeep Malviya

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.