Highlighted
Absent Member.
Absent Member.
5610 views

Load Generator Failed

Hello,

I am facing Load generator failure very frequently for the past two weeks. There were no Hardware nor Software upgardes that were made during the time period. Please find below the Errors i get. Kindly help me to resolve.

Error: Client (-server_type=8)(-server_ip_name=xxx.xxx.xx.xxx)(-server_port=xxxxx)(-server_fd_primary=2)(-user_extra_data=IP) is not responding.

Error: Service client with id=303 failed to post a message ,reason - target process/thread doesn't exist. [MsgId: MERR-29739]

Error: Communication error: The Client failed to send packet. The socket has been shut down. [MsgId: MERR-10343]

Thanks
John
0 Likes
3 Replies
Highlighted
Absent Member.. Absent Member..
Absent Member..

LoadRunner Agent Process/service starts itself at port 50500 and 54345 (For monitoring/running vuser over firewall, it is port 443). Do a netstat -an on the machine and check to see if 54345 and 50500 are occupied. If these ports are in used when you start the agent, you will get the above error. You will need to shut down the application that is using those ports, so that the ports are freed before restarting LoadRunner agent.

You may also get this error during replay if LoadRunner agent of the host machine is connecting back to the controller using a port that is already bound. By default, this is a dynamic port and LoadRunner agent will automatically try a different port.

If you would like to fix this port, however, refer to Document ID 11279 - Which ports need be open between the Controller and Host for connection

~~Shivaram
0 Likes
Highlighted
Absent Member.
Absent Member.

The document referenced above is not correct
would you please provide the correct doc ID

Thanks
0 Likes
Highlighted
Absent Member.
Absent Member.

Probably this could be due to  NIC configuration issue.  Can you please change it  to 100 mbps/Full duplex from the default value of Auto and check?

 

this can be done as below


From LAN connection - properties - click configure
- from advanced tab select Link speed & duplex property and change the value.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.