Highlighted
Absent Member.
Absent Member.
429 views

LoadRunner Click and Script Usage

Has anyone has success using the Web Click and Script protocol within LoadRunner? We recently upgraded to LR v9.51. In past versions, we tried to use Click and Script, but had issues with recording/playback so we always went back to the standard Web HTML/HTTP protocol.
If you have had success, I would appreciate any hints & tips in using this protocol.
0 Likes
3 Replies
Highlighted
Absent Member.
Absent Member.

Re: LoadRunner Click and Script Usage

Even i tried using the Web Click and Script protocol.Didn't work for me.So went back to HTML/HTTP.now safe and sound.
BTW what is it you feel is there in C&S which is not there in HTTP/HTML which would make your current work easier ?
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LoadRunner Click and Script Usage

We've been told since LR 8.1 FP4 that C&S would save us scripting time by reducing the need for correlation. I've been using LR for about 10 years so I'm very comfortable with both manual and auto-correlation in HTML/HTTP. However, we have some less-experienced LR analysts that have difficulty with applications that require a lot of correlation. So we were hoping the C&S could help. However, I've never really heard from anyone that thought it providing the stated benefits.
0 Likes
Highlighted
Established Member..
Established Member..

Re: LoadRunner Click and Script Usage

Hi Robin,

I think I am approaching the right person.I hope you can give the solution the problem which I am facing.

Could you please help me on the below.

Basically I added the below web text check points to make sure whether user has really logged in or not

//After Login//
web_find ("web_find",
"RightOf=for",
"LeftOf=Account",
"What=Summary",
LAST);

//After Logout//
web_find ("web_find",
"RightOf=logged out",
"LeftOf=you have",
"What=successfully",
LAST);

1) I got the below error
Action.c (1428): Error -27195: "web_find" failed. 0 occurrence(s) of "successfully" found (RightOf="logged out", LeftOf="You have") [MsgId: MERR-27195]
Action.c(1428): web_find highest severity level was "ERROR" [MsgId: MMSG-26391]
2)I noticed in the Replay Log after adding and ran the script by using above checkpoints , correlation parameters are not registered.
3)afrWindowId is registers and substitutes with empty values
4)For afrLoop55 & afrLoop48 registers and subtitues the same dynamic value.I know I gave the same LB and RB boundary.The reason why I gave the same is when i looked in the Recording Log RB&LB are same for both and i have to place both param on the top i.e before the same Web_url.I tried by giving various RB and putting the param in different locations, but no use.

6)when I looked into Recording & Replay screenshots it says "Your browser has not Java script enabled even though IE8 has JS enabled. I am using Web(Http/Html) protocol .Is Web(Http/Html) protocol supports JS applications.
7)in this situation how can I Debug without screenshots and how to I add check points.
8)could you please check my script, am I doing right

Please find the script as an attachment.

Please advise me!

Thanks,
Raj
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.