Highlighted
Absent Member.
Absent Member.
2976 views

Loadrunner 9.1 Replay Error.

Hi,

I am new to LoadRunner. I am using LR 9.10 .
I recorded a login, same acctions and logout action for an web (clicK & Script) application. the recording at the first time is wel but
when i do a replay back i get the below said error.

Action.c(16): Error -26224: Edit field not found [MsgId: MERR-26224]
Action.c(17): Error -26161: Frame not found in browser/dialog [MsgId: MERR-26161]
Action.c(17): No FRAME/IFRAME object found in the specified browser [MsgId: MMSG-26159]
Action.c(17): web_text_link("Berichtenbox") highest severity level was "ERROR" [MsgId: MMSG-26391]
It would be great if you help me resolve this error.

Thanks
Mourad
0 Likes
14 Replies
Highlighted
Established Member..
Established Member..

Re: Loadrunner 9.1 Replay Error.

Hi,

Is there any specific reason you have used web(Click & Script) protocol?

Why don't you make use of Web(HTTP/HTML) protocol. If there also you get this kind of problem. Definitely you will have to correlation problem.

If you get any problem let me know we will find out what could be the resolution for the same.


Thanks
Ajay
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Loadrunner 9.1 Replay Error.

Hi Ajay
thanks for your replay.
I try at first web(HTTP/HTML) but the LR is not able to record anything I got no actions no snapshot at the end (empty script) so why I tried web(Click & script) my actions be recorded but the playing back be failed (the error above),
Help please⠦⠦⠦.
Thanks in advance
Mourad
0 Likes
Highlighted
Established Member..
Established Member..

Re: Loadrunner 9.1 Replay Error.

Hi,

Do one thing. First let us work with Web (HTTP/HTML) Protocol options.

Try recording as mentioned below:

Open Vugen > Recording Options > Port Mapping > Select Capture level data as WinInet. Now try recording It should get caputered

If this also doesnâ t work then.

Try with out as you are able to record in Web(Click & Script) Protocol.

Follow certain steps to find out what could be the problem which caused error while play back.

1. Record two script with same steps and same inputs during record session.
2. Now compare both the script carefully. I you are aware of compare script functionality make use of it else compare each single code manually and find out what is the difference.

Good Luck!!!!

Thanks
Ajay
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Loadrunner 9.1 Replay Error.

Hi Ajay
Thanks for your answer
I tried web(http/html) with the correct recording options (Winlnet) as you said, but it's got no actions (0 events) and it â s like of nothing be captured and de actions arenâ t detected. Here below I put the recording log maybe help you to recognize the error.
Thanks
Mourad
****** Start Log Message ******
Web Recorder version : 9.10.0.1593
Recording Mode: HTML-based script
Correlation is enabled system wide
Not recording headers
Not excluding content types
Do not record this content types as a resource:
text/html
text/xml
Reset context between actions
Record non-HTML elements in current HTML function
Protocol Type: Multi-QTWeb
$$$$$$ End Log Message $$$$$$
Code generation version: 9.10.0.908
0 Likes
Highlighted
Established Member..
Established Member..

Re: Loadrunner 9.1 Replay Error.

Hi,

From the start log message it looks fine. This will not give the reason why events are not getting captured.

Did you try out below steps which I mentioned in my earlier post?

Try with out as you are able to record in Web(Click & Script) Protocol.

Follow certain steps to find out what could be the problem which caused error while play back.

1. Record two script with same steps and same inputs during record session.
2. Now compare both the script carefully. I you are aware of compare script functionality make use of it else compare each single code manually and find out what is the difference.


Thanks
Ajay
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Loadrunner 9.1 Replay Error.

Hi,

I am getting the same problem og nothing being recorded with the HTTP/HTML protocol.

I have also tried the steps mentioned for the Winnlet settings, but still the problem has not been resolved.

It would be great if you could help me out to resolve this issue.

Thanks
Ann
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Loadrunner 9.1 Replay Error.

Hi, any fix for this issue, I'm also getting the same error. I tried the solution provided but when I start recording the home page says "Page cannot be displayed"
Please help ASAP
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Loadrunner 9.1 Replay Error.

Hi,

What kind of application you are trying to record? Is it a web based java or .Net application? Do you see any flash embedded?

since protocol is decided based on type of application.It would be better to have above details.


Regards,
Vinutha
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Loadrunner 9.1 Replay Error.

java web based application
I'm getting the following err:

Action.c(6): Error -26160: Browser not found [MsgId: MERR-26160]
Action.c(6): There is no context for GUI-based functions. A web_browser(... "Navigate=" ...) may be missing, or the context has been reset (e.g., all windows closed or an HTML-based function called) [MsgId: MMSG-26204]
Action.c(6): web_element("Test3(TEST3)") highest severity level was "ERROR" [MsgId: MMSG-26391]
Abort was called from an action.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Loadrunner 9.1 Replay Error.

I am also facing the same issue. I have recorded the scenario but there are no actions and no snapshots captured. I have checked with all three options of capture level as mentioned in above posts.

Please anyone here can help me to resolve this issue?
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Loadrunner 9.1 Replay Error.

Hi,

Even i am facing the same problem.

LR Version - 9.1
Protocol - AJAX (Click and Script)

Error - Action.c(477): web_text_link("New Entry") highest severity level was "ERROR" [MsgId: MMSG-26391]

Please let me know how to resolve this

Thanks
Arindam
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.