Highlighted
Absent Member.. Absent Member..
Absent Member..
1248 views

MQ Scripts are not running on ALM 11

Hi Team,

 

I have MQ scripts prepared in Loadrunner 8.1.

I uploaded scripts on ALM11 and while trying to run the script users are directly going to error and in output.mdb file I am getting below error.

 

Error Message:
Error (-81049): LR_VUG: Cannot open LRP file for type 'MQSeries-Client'.
Error: The user files were not transferred to the local load generator
Error: Communication error: Linked List client failed to initialize server pointer.
Error: Communication error: Linked List client failed to initialize server pointer.
Error: Failed to create custom channel client on main thread(connection string: (-server_type=6)(-guid_identifier=HU9B+M4Vg0C_i_JiF+Owvw==)(-ll_server_index=9)).

 

Could you please let me know what is the issue? or if anything I am missing.

 

Performace Center already contains MQ Client in LG.

 

I also try manually adding "MQSeries-Client.lrp" and "MQSeries-Server.lrp" files to the script but no luck.

 

Your help will be highly appreciated.

 

Thanks,

Kamal Shingala

0 Likes
4 Replies
Highlighted
Super Contributor.
Super Contributor.

Re: MQ Scripts are not running on ALM 11

Hi Kamal,

 

There is a known issue regards MQ Scripts.

Please copy the following lrp files on your Performance Center servers (<PC installation folder>\dat\protocols\😞

MQSeries-Client.lrp
MQSeries-Server.lrp

 

Refer to the following KB for more information (and locations of the original files) : http://support.openview.hp.com/selfsolve/document/KM1285167

 

Regards,

./SA

Thanks,

./Sebastien
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: MQ Scripts are not running on ALM 11

Hi Team,

 

Thanks for you reply,

 

Actually I had already copied these files inside given folder.

 

From "C:\Program Files\HP\LoadRunner\dat\protocols" to Respective folder of Performance Center host in LG.

 

Initially we were not able to view script on ALM. After completing above steps we are able to view the scripts now.

 

However still the scripts are not working.

 

Please suggest anything I am missing.

 

Thanks,

Kamal Shingala

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: MQ Scripts are not running on ALM 11

Hi Team,

 

Any suggestions?

 

I am still facing the same issue.. Double checked the LG, It has required .lrp files in correct folder. We also have MQ client and MQ tester installed on LG.

 

The same MQ script is working on PC 8.1 but it's giving me error: "unable to open LRP file" in ALM 11.00 and users are directly going to error.

 

Your help will be highly appreciated.

 

Thanks,

Kamal Shingala

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: MQ Scripts are not running on ALM 11

Hi All,

 

I am not sure If we can use and run MQ scripts in ALM 11. For now we have converted our MQ scripts to Java vusers Protocol and which sends message to appropriate queue.

 

But still if you can tell me how to use MQ scripts in ALM then Thanks in Advance!! 🙂 😉

 

Thanks

Kamal Shingala

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.