Highlighted
Absent Member.
Absent Member.
421 views

No Error received, yet replay not working correctly.

Hi,

I am new to Load Runner and require some help from you.
I am working on an application where we create some quote and do various operation on it after saving the quote.

Right now I am just creating a simple quote.

1. Login (secure authentication OFF, no passwords)
2. Typing the parts name in text box.
3. Selecting Add Part from dropdown menu.
4. Saving the quote.
5. Logout.

I have no problem in recording.
When Replaying the script, New quotes should be created in the application, which is not happening.

I understood the problem of session but in the replay logs I can see new session id everytime I run the script.

Please see attached HTTP request comparison in the screenshot.

Thanks
Abhinav
0 Likes
5 Replies
Highlighted
Established Member..
Established Member..

Re: No Error received, yet replay not working correctly.

Hi Abhinav,

This could be due to correlation.

You need to see few things as mentioned below:

1. Check if every created quote is associated with any uniqe number?

2. Try Ctrl+F8 it will check the dynamic values for auto correlation. If it detects any value selct the value and click on correlate button at correalation bottom window.

3. If auto correlation 2nd step doesnt find any dynamic value then you need to check manually the dynamic value and correlate.

4. Probably you will see dynamic value at server response (Tree View) of Saving the Quote request. As this is the step where your quote is getting created.

Good Luck!!!!

I am sure correlation will solve your problem.

Thanks,e
Champ
1.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: No Error received, yet replay not working correctly.

Thanks Ajay

Yes quote is saved as a unique no.

I will try to find manually any correlation as no correlation is found automatically.

I will update you once I manage to get something new.

Thanks again
Abhinav
0 Likes
Highlighted
Established Member..
Established Member..

Re: No Error received, yet replay not working correctly.

Hi Abhinav,

Let me say this why your script is not able to create new quote with Vugen.

As you said it creates quote with unique number. Did you try creating new quote with already created quote number I am sure you will not be able to do that as it is uniqe and generated at backend (from Server).

In similar why when you recorded your script with Vugen in reality you have created new quote which has it unique ID. Now when you run the script it finds same hard coded unique ID which got captured while recording which stops your script to create new quote. So what all you need to search that unique ID at Server Response in tree view and correlate it. I believe then your script will be all set.

Good Luck!!!!

Thanks,
Champ
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: No Error received, yet replay not working correctly.

Thanks Ajay for this new point. I will have to search for this in the script.
But I have tried to search and email the quote (functionality present in the app), but same issue was present at that time too. No email was generated...

Also, sessionid is coming only in client and server responses and not in the script. If I make a parameter of sessionid in server response, how to reflect it to the rest of the script.

Thanks
Abhinav
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: No Error received, yet replay not working correctly.

Hi Ajay,

I am still not able to remove correlation problem from my script.
This is what I am doing:

1. open url
2. enter user name password
3. select option from dropdown(this decide a category of quote)
4. click search
5. enter quote no. or date range for quote to be searched
6. select the searched quote through radio button
7. all the details get populated according to the quote
8. select email
9. enter details in new email page.
10. click send
11. click logout
12. click yes

I don't get any error massage. I have compared two scripts and removed the differences. Still no success.

While comparing the screenshots from recording to replay, I can see error in replay that quote needs to be saved before email this means script is just pasting the stored values.

the session details are not recorded in action.c file but can only be seen in client and server details.

Can you please help me in this issue???


Thanks
Abhinav 😞
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.