Highlighted
Absent Member.
Absent Member.
571 views

Not authorised to view page but appears working

~Afternoon
I have a script that I thought was working correctly as it's doing a web check on page. But today I turned on data returned by server just to view and have noticed that I am getting HTTP Error 401.2 - Unathorized: Access is denied due to server configuration

Please Help
0 Likes
7 Replies
Highlighted
Absent Member.
Absent Member.

Re: Not authorised to view page but appears working

Question ~Afternoon
I have a VuGen script that I thought was working correctly as it's doing a web check on page. But today I turned on data returned by server just to view and have noticed that I am getting HTTP Error 401.2 - Unathorized: Access is denied due to server configuration

Please Help
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Not authorised to view page but appears working

what kind of a webcheck are you doing. Are you checking for a specific text that appears in your page?

Also in RTS > Preferences > Enable Image and Text Checks.

Finally you can have a webglobal verification on the text "Unauthorized Access" and set it to fail if found
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Not authorised to view page but appears working

Thanks
I have enabled the webcheck, I'm not sure about the webglobal. On the script when I select data returned by server I can view this error being returned, but yet the scripts appear to be logging into the site and returning the correct values.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Not authorised to view page but appears working

web_global_verification("Text/IC=HTTP Error 401.2 - Unauthorized: Access is denied", "Fail=Found", "ID=401 Error", LAST );

it will catch the error if it pops up.. place it at the begining of your action / login step.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Not authorised to view page but appears working

"returning the correct values."

how did you determine this?

what is visible in your run time browser?
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Not authorised to view page but appears working

Sorry I was off on leave.

I have several checks, text, returncode for size and code200.

within Internet Protocol I have enabled WinInet replay instead of sockets. This appears to have resolved the issue of this error message.

I will close this thread, thank-you for all the reponses.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Not authorised to view page but appears working

within Internet Protocol I have enabled WinInet replay instead of sockets. This appears to have resolved the issue of this error message.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.