Highlighted
Valued Contributor.. Valued Contributor..
Valued Contributor..
1212 views

PC Server Installation - Configuration Failed - User [IUSR_METRO] does not exists or bad password

Jump to solution

Hi, I am trying to install Perormance Cetner Server v12.55 onto a Windows 2012R2 Server. The configuration wizard is repeatedly failing with the error:  Failed to configure user. Error: HP.PC.Common.Exceptions.SysIdentityException: User [IUSR_METRO] does not exists or bad password

I opted to keep the default user name .\IUSR_METRO but I have changed the password. The password I am using is at least 12 characters long and includes numbers, special characters and upper & lower case letters. As per the installation guide the password does not include the characters: < > | & " ^ or space

From Windows 'Computer Management' I can see that the IUSR_METRO account has been created as a local user account. However the user is not a member of any groups.

From the installation log:

Target RunAfterInstall:
    Target CreateUser:
        Configuring user....
        D:\Program Files (x86)\HPE\Performance Center Server\dat\Setup\PCS\MSBuild\HP.PC.PCS.MSBuild.proj(342,3): error : Failed to configure user. Error: HP.PC.Common.Exceptions.SysIdentityException: User [IUSR_METRO] does not exists or bad password
        D:\Program Files (x86)\HPE\Performance Center Server\dat\Setup\PCS\MSBuild\HP.PC.PCS.MSBuild.proj(342,3): error :    at SystemConfig.ConfigurationSteps.CreateUserStep.TestAction()
        D:\Program Files (x86)\HPE\Performance Center Server\dat\Setup\PCS\MSBuild\HP.PC.PCS.MSBuild.proj(342,3): error :    at SystemConfig.Configuration.ServerConfigurationManager.ExecuteStep(ConfigurationStepBase step)
        D:\Program Files (x86)\HPE\Performance Center Server\dat\Setup\PCS\MSBuild\HP.PC.PCS.MSBuild.proj(342,3): error :    at SystemConfig.Configuration.ServerConfigurationManager.ChangeIdentitySteps(SystemIdentity si)
        D:\Program Files (x86)\HPE\Performance Center Server\dat\Setup\PCS\MSBuild\HP.PC.PCS.MSBuild.proj(342,3): error :    at SystemConfig.Configuration.ServerConfigurationManager.ChangeIdentity(SystemIdentity sysIdentity)
        D:\Program Files (x86)\HPE\Performance Center Server\dat\Setup\PCS\MSBuild\HP.PC.PCS.MSBuild.proj(342,3): error :    at SystemConfig.Configuration.ServerConfigurationManager.ChangeServerIdentity(String currentUser, String currentPass, String currentGroup, String newUser, String newPass, Boolean deleteOldUser, Boolean changePassOnly, String newGroup, Boolean isAdminGroup, Boolean deleteOldGroup, Int32 machineType, String configurationUser, String configurationPass, Boolean configureOnlyUser)
        D:\Program Files (x86)\HPE\Performance Center Server\dat\Setup\PCS\MSBuild\HP.PC.PCS.MSBuild.proj(342,3): error :    at HP.PC.MSBuild.Tasks.Tasks.PCSetServerIdentityTask.Execute()
[10/09/2018 16:21:40]: Target CreateUser Finished
    Done building target "CreateUser" in project "HP.PC.PCS.MSBuild.proj" -- FAILED.
[10/09/2018 16:21:40]: Target RunAfterInstall Finished
Done building target "RunAfterInstall" in project "HP.PC.PCS.MSBuild.proj" -- FAILED.

If I delete the user and run the configuration wizard again the account is re-created but the same error message is encountered.

If I don't delete the user and try to run the configuration wizard again then, when I click 'Next' on the 'Create the Performance Center User' page, I get a pop-up message "Configuration Error:  Username or password is incorrect" and cannot progress through the wizard.

Thanks,

Phil

 

0 Likes
1 Solution

Accepted Solutions
Highlighted
Valued Contributor.. Valued Contributor..
Valued Contributor..

Re: PC Server Installation - Configuration Failed - User [IUSR_METRO] does not exists or bad passwor

Jump to solution

Resolved:  It turned out that there was a Global Policy Object (GPO) that set the policy to: "deny access to this computer from the network" to include local administrator users.

Because the IUSR_METRO account is a local administrator account this GPO was preventing the configuration from working.

Thanks for your responses,

Phil

View solution in original post

0 Likes
6 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: PC Server Installation - Configuration Failed - User [IUSR_METRO] does not exists or bad passwor

Jump to solution

Hi Phil,

Did you try running the configuration without changing IUSR_METRO password? I am not suggesting the password cannot be changed, I just wonder if that is the reason for the failure.

Can you please open a support ticket? We need to involve PC experts to resolve that.

Regards,
Shlomi

0 Likes
Highlighted
Micro Focus Contributor
Micro Focus Contributor

Re: PC Server Installation - Configuration Failed - User [IUSR_METRO] does not exists or bad passwor

Jump to solution

Hi Phil,

If the user is a local user, please provide it as follows: "[Domain]\[UserName]", where Domain is the name of the machine.

Kind regards,

Andrei 

0 Likes
Highlighted
Valued Contributor.. Valued Contributor..
Valued Contributor..

Re: PC Server Installation - Configuration Failed - User [IUSR_METRO] does not exists or bad passwor

Jump to solution

Resolved:  It turned out that there was a Global Policy Object (GPO) that set the policy to: "deny access to this computer from the network" to include local administrator users.

Because the IUSR_METRO account is a local administrator account this GPO was preventing the configuration from working.

Thanks for your responses,

Phil

View solution in original post

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: PC Server Installation - Configuration Failed - User [IUSR_METRO] does not exists or bad passwor

Jump to solution

Glad to hear it was resolved. Thanks for sharing the resultion details.

Regards,
Shlomi

0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: PC Server Installation - Configuration Failed - User [IUSR_METRO] does not exists or bad passwor

Jump to solution

Hi All,

My PC 12.55 installation is going but but when i try to login iam getting error as  "Failed to verify your username and/or password. Please try again, or contact your system administrator" .I tried with IUSR_METRO and  service account  but still the same error.any solution.

 

 
0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: PC Server Installation - Configuration Failed - User [IUSR_METRO] does not exists or bad passwor

Jump to solution

Hi @Umakasturi,

I suggest opening a new post since you experience a different issue and it will just confuse others if the discussion continues here on that.

Regards,
Shlomi

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.