Highlighted
Super Contributor.. Super Contributor..
Super Contributor..
151 views

PC graphs are not appearing while executing the test on PC v12.63

Jump to solution

We recently built a new PC v12.63 environment and tried to run some sample PC tests to ensure everything is OK or not. All the connections & configurations are fine but when we tried to run a perf test, we are unable to see any kind of PC graphs while executing the tests. It shows like :loading" but after sometime it says "No Data". But when we stop the test and see the results of that test, we can able to see the graphs with all the data.

Labels (2)
0 Likes
1 Solution

Accepted Solutions
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: PC graphs are not appearing while executing the test on PC v12.63

Jump to solution

We have opened all the FW rules as per the performance center architecture diagram including all the PC components but still had this issue. But we figured out that the problem is due to the controller server time sync issue with the other PC & ALM servers. 

Normally, all the ALM servers and PC server and its components like Controllers, MI Listener & Data Processor machines needs to be aligned on same time zone with exact time sync. But in our case, the problematic server(Controller) time is 7 min ahead of the timing which is there on the remaining servers. So, this is why when ever we start our performance test, we used to see the graphs only after 7 min of start of the test. By aligning the server timing with the other servers has made to solve this issue for us.

Thumb Rule:- In order to have seamless connectivity and to perform performance tests successfully without any issues, you need to have all the necessary FW rules to be opened between the required QC & PC components and ensure to maintain the same time zone on all these servers.

View solution in original post

Tags (3)
2 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: PC graphs are not appearing while executing the test on PC v12.63

Jump to solution

Hello, 

This behavior might happen if the port 8086 on the controller does not allow traffic. Crete a rule to allow IP traffic bi-directionally on the controller and try again.

An example how open the port below:

https://www.howtogeek.com/394735/how-do-i-open-a-port-on-windows-firewall/

Best,

Ivo

IvoHri
0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: PC graphs are not appearing while executing the test on PC v12.63

Jump to solution

We have opened all the FW rules as per the performance center architecture diagram including all the PC components but still had this issue. But we figured out that the problem is due to the controller server time sync issue with the other PC & ALM servers. 

Normally, all the ALM servers and PC server and its components like Controllers, MI Listener & Data Processor machines needs to be aligned on same time zone with exact time sync. But in our case, the problematic server(Controller) time is 7 min ahead of the timing which is there on the remaining servers. So, this is why when ever we start our performance test, we used to see the graphs only after 7 min of start of the test. By aligning the server timing with the other servers has made to solve this issue for us.

Thumb Rule:- In order to have seamless connectivity and to perform performance tests successfully without any issues, you need to have all the necessary FW rules to be opened between the required QC & PC components and ensure to maintain the same time zone on all these servers.

View solution in original post

Tags (3)
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.