Highlighted
Established Member..
Established Member..
151 views

PC tests with header files do not run

We are in the process of upgrading from LoadRunner (LR) 11.0 to Performance Center (PC) 11.52 and have a run into an issue and need some assistance.

We have written a few new basic VuGen 11.52 scripts (very simple functionality (e.g. call a function and return)).

The scripts run fine in VuGen, but they will not run in the PC 11.52 environment.

We have moved the function header file into the VuGen project and also tried another test with external references, but neither work.

We get the following errors:
19799-Error: CCI compilation error -In file included from j:\program files (x86)\hp\load generator\temp\brr_eg0.214\global_dir\99611384\combined_37.c:3:

19797-Error: Vuser compilation failed. Please set CCIDebug to Off in CCI section of mdrv.dat file.

47295-Message "Monitor name :Host Monitor. Cannot access data for measurement Processor
% Processor Time
_Total on machine usgobtpclg800.
Details: A counter with a negative denominator value was detected.

Hint:
Check that there is such a measurement on the machine (use the Add Machine dialog box) (entry point: CNtMeasurement::GetNewData3). [MsgId: MMSG-47295]"
Please see attachemnets for details description for the issue we are getting and related project zip files.

0 Likes
2 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: PC tests with header files do not run

Hi,

 

Please check ther following document:

Error when replaying scripts that access resources from a network folder

http://support.openview.hp.com/selfsolve/document/KM549141

 

Kind regards,

Vesela

HPE Support
If you haven’t tried it yet, come and join us in our entitled forums at Support Customer Forums

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution and give Kudos to the author for their assistance.
0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: PC tests with header files do not run

Hi

In addition of Vesela information above, you have two different errors. The first one is about a compilation error into the Load Generator machine for an included file, possible for the app under test and which is not present in the LG machine. Please check above Vesela KM suggested or try to add the file requested by the LG as an extra files into the “Extra Files” section.

The second one is about a counter problem. Please check the following KM0065105

 

Rodolfo Leitón

HP LR/PC Support

If you are customer you can try posting on our internal forums for more personalized support.

For LoadRunner here.
For Performance Center here.

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.

If you found this information useful please leave a kudo.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.