Highlighted
Valued Contributor.. Valued Contributor..
Valued Contributor..
186 views

Performance Center 11.52 - Why is Citrix so difficult in PC vs LR Controller?

Performance Center has been a nightmare trying to execute Citrix scripts.  Scripts run fine in VuGen but fail in PC on a consistant basis (even with one user).  Productivity is way down when it takes this long to get a single script stable in PC.  Any tips would be great.

0 Likes
3 Replies
Highlighted
Honored Contributor.
Honored Contributor.

Re: Performance Center 11.52 - Why is Citrix so difficult in PC vs LR Controller?

Hi

The Load Generator is the component that run the script when load test in PC. Most of the errors is regarding a problem with the LG. In addition with Citrix we need a client working with the script. You need to analyze the error first to perform a troubleshooting. If you have Citrix connection error I suggest try to run the LG as a process using a user that you know doesn’t have problem to connect with the Citrix Server.

 

With the client you need to check that is a version supported and in the LG you have installed the Citrix patch. Check the LR Readme to install the Enable_Citrix_API.reg.

 

Very helpful is view one vuser session running in a LG. Check this KB to know how KM8217459.

 

Rodolfo

0 Likes
Highlighted
Valued Contributor.. Valued Contributor..
Valued Contributor..

Re: Performance Center 11.52 - Why is Citrix so difficult in PC vs LR Controller?

I have been testing Citrix for over 7 years, the first 6 using LoadRunner and the last year or so with Performance Center.  Since the script replays fine on the LG I know the user and the Citrix client work fine.  The issue is always with executing the scripts through Performance Center.  I had bitmaps today that failed and yet the bitmap that was seen was the exact same has as what it said it couldn't find.  Tell me how that happens.

 

 

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Performance Center 11.52 - Why is Citrix so difficult in PC vs LR Controller?

Hi,

 

This sounds like a synchronization issue during replay. What is the Default Image Sync Tolerance: Exact -  100% match, Low -  95% match,  Medium - 85% etc? If you set the tolerance to high will there be a difference in the snapshot recognition?

If the script replays without issues on the load generator, a possible reason could a difference in the Run Time Settings.

Please compare  the content of the file default.cfg in the script folder when you run it successfully on the load generator machine and when you run a test from Performance center. You can find the default.cfg file during the test execution in the Temp folder on the load generator machine. Please check the value of BitmapSyncLevel and other values under [CITRIX] ,   [TIMEOUT] and [ThinkTime]

Kind regards,
Vesela

 

HPE Support
If you haven’t tried it yet, come and join us in our entitled forums at Support Customer Forums

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution and give Kudos to the author for their assistance.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.