Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..
1322 views

Performance Center Host Install Issue

Jump to solution

Hi,

I am trying to install a Performance Cernter host but I keep getting an error: I think it might have something to do with HP.PC.LTS.MSBuild.proj but I cannot remember whatI did in the past to workaround this issue.

The PC Host Configuration process failed. In the log I see this:

erformance Center Host Configuration Wizard started.
[11/28/2017 6:53:16 AM]: User input file is 'D:\Program Files (x86)\HP\Performance Center Host\dat\Setup\LTS\Xml\UserInput.xml'.
[11/28/2017 6:53:22 AM]: User config file does not contain value for SSO Token. Take value from app config file
[11/28/2017 6:54:09 AM]: [WARNING]: Task calculation operation on MsBuild file failed.
File: D:\Program Files (x86)\HP\Performance Center Host\dat\Setup\LTS\MSBuild\HP.PC.LTS.MSBuild.proj
[11/28/2017 6:54:09 AM]: [WARNING]: Message: The element 'Target' in namespace 'http://schemas.microsoft.com/developer/msbuild/2003' has invalid child element 'PCServiceControllTask' in namespace 'http://schemas.microsoft.com/developer/msbuild/2003'. List of possible elements expected: 'Task, AL, AspNetCompiler, AssignCulture, AssignProjectConfiguration, AssignTargetPath, CallTarget, CombinePath, Copy, CreateCSharpManifestResourceName, CreateItem, CreateProperty, CreateTemporaryVCProject, CreateVisualBasicManifestResourceName, Csc, Delete, Error, Exec, FindUnderPath, FormatUrl, FormatVersion, GenerateApplicationManifest, GenerateBootstrapper, GenerateDeploymentManifest, GenerateResource, GenerateTrustInfo, GetAssemblyIdentity, GetFrameworkPath, GetFrameworkSdkPath, LC, MakeDir, Message, MSBuild, ReadLinesFromFile, RegisterAssembly, RemoveDir, RemoveDuplicates, ResolveAssemblyReference, ResolveComReference, ResolveKeySource, ResolveManifestFiles, ResolveNativeReference, ResolveNonMSBuildProjectOutput, ResolveVCProjectOutput, SGen, SignFile, Touch, UnregisterAssembly, UpdateManifest, Vbc, VCBuild, Warning, WriteLinesToFile, CreateJSharpManifestResourceName, Vjc, VjsResGen, CodeAnalysis, PCDeleteUserDetailsTask, PCSetINIFileKeyValueTask, XmlAttributeTask, XmlNodeTask, XmlAddNewNode, PCGetAp....
Build started 11/28/2017 6:54:09 AM.

 

 

 

0 Likes
1 Solution

Accepted Solutions
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: Performance Center Host Install Issue

Jump to solution

Ah!

I also saw this in the log file:

ERROR HP.PC.ServiceModel.Errors.ErrorHandler - HP.PC.Common.Exceptions.PCServiceException: Host's installation is invalid. ---> System.Security.Authentication.AuthenticationException: The ALM Connection settings (Internal URL, external URL) are incomplete. To update the settings, click the ALM Connection button in the PC Server module toolbar.

So I went to Lab Management, PC Servers and clicked ALM Connection.

After this I was able to add my host.

View solution in original post

0 Likes
5 Replies
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: Performance Center Host Install Issue

Jump to solution

Ok, so I uninstalled and reinstalled the Performance Center Host 12.55.

This time there were no errors and so I tried to add the host in Lab Manager.

Now I get an error telling me: Host's installation is invalid!

I have tried using both the host name and it's IP.

UAC and DEP are disabled

 

0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: Performance Center Host Install Issue

Jump to solution

I can see that the host appears to be installed.

I looked on Control Panel -> Programs and I see HPE LoadRunner Version 12.55.646.0

Also tried running the repair tool.

Still I get the error when I try to add the host in Lab Management - Host's installation is invalid!

0 Likes
Highlighted
Super Contributor.
Super Contributor.

Re: Performance Center Host Install Issue

Jump to solution

Hi,

Couple of things you may want to check:

* All services running on the host (RemoteManagement, Agent, LTOP, Secondary Logon, etc.),

* Do you have a firewall? Ports open (check the PC server logs for error orchidtmp\LTLogger\w3wp)

Thanks,

./Sebastien
0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: Performance Center Host Install Issue

Jump to solution

Services are all up.

Checked the log file you mentioned and I see this:

017-11-28 08:55:42,999 [5516] [95] ERROR HP.PC.Host.Management.BL.Model.HostChecks.RemoteChecks.LGLightWeightConnectionCheck - Failed connecting to LG LGSERVER1 [Context: a49987cb-ef1c-41f6-b86c-f54018b1ac93] [FullContext: QCServer:http://myperformancecenter:8080/qcbin UserName:_pc_system_ Domain:DEFAULT Project:LAB_PROJECT]
System.Net.Sockets.SocketException (0x80004005): No connection could be made because the target machine actively refused it xx.xxx.xxx.xxx:54345
at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
at HP.PC.Host.Management.BL.Model.HostChecks.RemoteChecks.LGLightWeightConnectionCheck.EndConnectionCallBack(IAsyncResult ar) in d:\Jenkins\workspace\PC-12-55-CI\app\Lab\HP.PC.Host.Management\HP.PC.Host.Management.BL\Model\HostChecks\RemoteChecks\LGLightWeightConnectionCheck.cs:line 185
2017-11-28 08:55:42,999 [5516] [13] ERROR HP.PC.Host.Management.BL.Model.HostChecks.RemoteChecks.LGConnectionCheck - Cannot connect to LG LGSERVER1 [Context: a49987cb-ef1c-41f6-b86c-f54018b1ac93] [FullContext: QCServer:http://myperformancecenter:8080/qcbin UserName:_pc_system_ Domain:DEFAULT Project:LAB_PROJECT]

 

Does this mean that my PC Server is trying to communicate with my LG Server via port 54345 and it cannot do so?

0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: Performance Center Host Install Issue

Jump to solution

Ah!

I also saw this in the log file:

ERROR HP.PC.ServiceModel.Errors.ErrorHandler - HP.PC.Common.Exceptions.PCServiceException: Host's installation is invalid. ---> System.Security.Authentication.AuthenticationException: The ALM Connection settings (Internal URL, external URL) are incomplete. To update the settings, click the ALM Connection button in the PC Server module toolbar.

So I went to Lab Management, PC Servers and clicked ALM Connection.

After this I was able to add my host.

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.