Highlighted
Absent Member.
Absent Member.
2537 views

Problem adding PC Server to ALM Server

Hi,

 

I have installed ALM and PC Servers on 2 different m/c, both are win 2008 r2 sp1. Now i am trying to configure PC under Lab Management. While trying to add the PC server, its throwing the below error -

 

'org.apache.cxf.service.factory.ServiceConstructionException: Failed to create service.'

 

Is it authorization issue or port availability issue. Please advise. Any help is appreciated.

 

Thanks,

Rahul

0 Likes
9 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Problem adding PC Server to ALM Server

Version of ALM & PCS Server & Patches installed on both?

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Problem adding PC Server to ALM Server

forgot to mention, version is 11.5... are there any patches for it ?

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Problem adding PC Server to ALM Server

Please attache error logs from PC Server + snapshot.

0 Likes
Highlighted
New Member.

Re: Problem adding PC Server to ALM Server

Were you able to fix this? I am having the same error when adding a new PC server.

 

ALM is win server 2008 SP2

PC is win server 2008 SP2

 

ALM PC version is 11.5

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Problem adding PC Server to ALM Server

1. Use IP address of PC server, when you are adding it.

2. Click ALM Connection in the right up corner and for both internal and external connection use http://alm-ip-address:8080/qcbin.

Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Problem adding PC Server to ALM Server

I wonder whether anybody has a fix for this issue.  I am running into the same issue:

 

javax.xml.ws.WebServiceException:org.apache.cxf.service.factory.ServiceConstructionException :Failed to Create Service

 

My installation is:

 

DB Server - Windows Server 2008 R2 SP1 - MS SQL Server

ALM Server - Windows Server 2008 R2 SP1 

Performance Center Server - Windows Server 2008 R2 SP1

 

The ALM Connection has been set and accepted as http://<ALM SERVER IP>:8090/qcbin - yes I changed to Port to 8090.

 

When I enter the PC Server name as <PC SERVER IP ADDRESS> and hit enter, I get the error listed above.  If there is anybody out there that has overcome this issue, please let me in on the secret.  

 

Ward

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Problem adding PC Server to ALM Server

Hello,

 

I am also facing similar issue while trying to add PC Server to ALM under Lab Management (Versions Used are 11.5 & Server OS is Win 2008). Is any service missing on the ALM instance or do I need to install any patch? Kindly guide me through this.

 

Thanks,

Chaitanya

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Problem adding PC Server to ALM Server

Any updates on this issue?

 

I ran into same situation with 2012 R2

0 Likes
Highlighted
Respected Contributor.
Respected Contributor.

Re: Problem adding PC Server to ALM Server

We also got similar error. After further analysis i found that during Server Maintenance (Security Patching  Activity) PC Server's 'IIS' got corrupted. So after re-installation of IIS & PC Server Software Issue got fixed.

 

Regards,

Abdul Kadir 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.