Highlighted
Absent Member.
Absent Member.
314 views

Problem with J2ee diagnostic

Hi;

I try to realize a tunning on a web application (Java/J2ee) in using HP J2ee diagnostic (version 8).
The probe works correctly but when I try to display via the GUI « ALL Methods » or « ALL SQL » I have any data and the page is empty ?

Q : How display these metrics ?

Regards
0 Likes
2 Replies
Highlighted
Absent Member.
Absent Member.

Re: Problem with J2ee diagnostic

What is your LR version? Did you install right version of Diagnostics plugin which supports your LR version?

Sometimes, the data might not be displayed in the graph but the reports includes the valid data. Did you try to verify the reports after test completion.

Diagnostics 8 is supported in LR 9.5x
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Problem with J2ee diagnostic

HP Diags 'Trims' and does not report any short running SQL or java calls by default. Diags will not report any SQL calls that run in less than 51ms.

You need to change:
In Dispatcher.properties file (on the probe)
minimum.fragment.latency = 51ms
minimum.sql.latency = 1s

Probably set both of those to 1ms

In capture.properties:
minimum.method.latency = 51ms

Set that to 1ms

Expect an INCREASE in the over head on the monitored JVM from doing this.. This means the probe has to collect and upload every SQL to the diags server.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.