NOTICE: Significant community changes coming soon
The header menu and the home page on our community will be changing soon. Get more information HERE.
Highlighted
Absent Member.
Absent Member.
108 views

Script in URL mode failing for a transaction.

Hi,

I have recorded a script using LR9.52 for an Web application. The flow is as follows Launch-> user1 - login -> create account -> logout ->user2-login ->search created account-> logout. User1 and User2 are differnt users. This script is recorded in URL mode. After the necessary correlation and parameterisation , when it is run, logout after search activity is failing. The same flow when recorded and replayed in HTML mode is replaying without any failures.


Attached is the URL hit which is failing in URL mode and Passing in HTML mode. when compared the difference found is "Mode=HTML" and "MODE=HTTP"

Would appreciate any help in this regard.
0 Likes
1 Reply
Highlighted
Absent Member.. Absent Member..
Absent Member..

Since it is the same command with the exception of the Referrer it should work. Turn on always log, parameter and data returned from server in the run time log settings and post the replay log from the command when played back in each script. This will help us give you more informed help.

Alan
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.