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Test Fails to reach desired concurrent user load level

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We have seen a recurring error on one of our Load Generators.

"Error: The user files were not transferred to LG_Server SCR_00"

As a result, the test fails to reach the desired concurrent user load level.

Can anyone please advise? Thanks.

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Re: Test Fails to reach desired concurrent user load level

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Hello 

 

Problem

When running VuGen scripts in Performance Center and the following error appears: "Error: The user files were not transferred to the local load generator."

 

Cause

The controller cannot transfer the script files to the Load Generator. When running a scenario in LoadRunner Controller / Performance Center, the Controller transfers the Vugen script files to the temporary location on the Load Generators. The temporary location will be created under <the load generator's temporary directory>\<brr folder>\netdir\<Path to the results folder on the controller>\<results name>. For example, if the script in Controller is stored in c:\VugenScript\Script1 and the Load Generator has the temporary folder set to C:\Documents and Settings\Default User\Local Settings\Temp, the Load Generator would save this script file in C:\Documents and Settings\Default User\Local Settings\Temp\<brr folder>\netdir\c\VugenScript\Script1. This is caused by a limitation of the maximum path length on Windows OS. The length limitation is 255 bytes in Windows XP and 260 bytes in Windows Vista. Please refer to MSDN: File Names, Paths, and Namespaces(http://msdn.microsoft.com/en-us/library/aa365247(VS.85).aspx) for more details on this limitation.

 

Fix

On the Load Generator: A. If you are running the agent as a process, you can change the "TEMP" system Variable of the user from C:\Documents and Settings\Default User\Local Settings\Temp to C:\Temp. The procedure is listed under KM172893 B. If you are running the agent as a service, you can change the service to use an account with Administration privileges, and change the admin account's "TEMP" system variable to a shorter path: - Go to Start -> Control Panel -> Administrative Tools -> Services.

- Look for the LoadRunner / Performance Center Agent Service.

- Right-click and select Properties->Log On, changing this from "Local System account" to "This account", supplying the Administrative account username and password.

- Follow the procedure from KM172893 to change the admin user temporary location.

PD: Information based on: KM902643

 

Regards,

Gean

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Trusted Contributor.. Trusted Contributor..
Trusted Contributor..

Re: Test Fails to reach desired concurrent user load level

Jump to solution

Hello 

 

Problem

When running VuGen scripts in Performance Center and the following error appears: "Error: The user files were not transferred to the local load generator."

 

Cause

The controller cannot transfer the script files to the Load Generator. When running a scenario in LoadRunner Controller / Performance Center, the Controller transfers the Vugen script files to the temporary location on the Load Generators. The temporary location will be created under <the load generator's temporary directory>\<brr folder>\netdir\<Path to the results folder on the controller>\<results name>. For example, if the script in Controller is stored in c:\VugenScript\Script1 and the Load Generator has the temporary folder set to C:\Documents and Settings\Default User\Local Settings\Temp, the Load Generator would save this script file in C:\Documents and Settings\Default User\Local Settings\Temp\<brr folder>\netdir\c\VugenScript\Script1. This is caused by a limitation of the maximum path length on Windows OS. The length limitation is 255 bytes in Windows XP and 260 bytes in Windows Vista. Please refer to MSDN: File Names, Paths, and Namespaces(http://msdn.microsoft.com/en-us/library/aa365247(VS.85).aspx) for more details on this limitation.

 

Fix

On the Load Generator: A. If you are running the agent as a process, you can change the "TEMP" system Variable of the user from C:\Documents and Settings\Default User\Local Settings\Temp to C:\Temp. The procedure is listed under KM172893 B. If you are running the agent as a service, you can change the service to use an account with Administration privileges, and change the admin account's "TEMP" system variable to a shorter path: - Go to Start -> Control Panel -> Administrative Tools -> Services.

- Look for the LoadRunner / Performance Center Agent Service.

- Right-click and select Properties->Log On, changing this from "Local System account" to "This account", supplying the Administrative account username and password.

- Follow the procedure from KM172893 to change the admin user temporary location.

PD: Information based on: KM902643

 

Regards,

Gean

View solution in original post

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