Highlighted
Absent Member.
Absent Member.
1673 views

Unable to connect Performance Center with REST API by browser/soap UI

Jump to solution

Hi Team,

I'm facing issue in connecting Performance Center using REST API. Getting "404 Not found" error while accessing the url in all the way that i have tried like in Browser/SOAP UI/Load Runner script/Fiddler/ VBA Macro.

RequestProperties : {
  Cookie=[], 
  Accept-Encoding=[gzip,deflate], 
  User-Agent=[Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; Trident/6.0)], 
  Content-Type=[application/x-www-form-urlencoded], 
  Accept=[*/*], Cache-Control=[no-cache]}
Sending 'GET' request:
URL: http://PCHostname/LoadTest/rest/authentication-poit/authenticate

URL: http://PCHostname/LoadTest/rest/authentication-poit/authenticate?login-form-required=y

 

Note: Referred "Performance Center 12.02 REST API Authentication problems" post but still facing the 404 issue.

Plesae help to resolve how to pass thorugh the issue.

 

Regards,

Mohan

 

 

0 Likes
1 Solution

Accepted Solutions
Highlighted
Absent Member.
Absent Member.

Re: Unable to connect Performance Center with REST API by browser/soap UI

Jump to solution

Resolved...Thanks every one.

The issue was with my attribute formats that i have used to send along with the request. Now successfully logged on to PC through REST API.

 

Regards,

Mohan

View solution in original post

0 Likes
8 Replies
Highlighted
Absent Member.
Absent Member.

Re: Unable to connect Performance Center with REST API by browser/soap UI

Jump to solution

Are you also passing your Base64 encoded username and password?

Authorization=Basic ksfhw98324hWFGDGDG
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Unable to connect Performance Center with REST API by browser/soap UI

Jump to solution

Yes, i'm passing the encoded username & password with the request.

Format used: Username:password (encoded)

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: Unable to connect Performance Center with REST API by browser/soap UI

Jump to solution

Hi,

The request method type should be GET

Url: http://<PcServer>/ LoadTest/rest/authentication-point/authenticate

The request should contain a header named Authorization with the value of the user name and password separated by : encoded using base 64 encoding;

Example:

GET /LoadTest/rest/authentication-point/authenticate

Authorization: Basic ABCDE123

If you don't succeed, please record the HTTP trafic in Fiddler and send the screen shot of the request response.

Regards,

Eyal

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Unable to connect Performance Center with REST API by browser/soap UI

Jump to solution

Thanks for the suggestions,

I tried the with smilar request format but still facing "404 - Not Found" error when accessing the url.

It seems the host is not configured/enabled to support REST API, can anyone help me on how to configure Performance center to support REST API.

Are there any other possible workaround on REST API calls?

 

Regards,

Mohan

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: Unable to connect Performance Center with REST API by browser/soap UI

Jump to solution

Hi,

You are mentioning the PC host in your url, altough the REST API is accesible only from PC server.

Are you sending the request to PC server?

As I suggested, please send the screenshot of the HTTP request recoreded by Fiddler.

Thanks,
Eyal

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Unable to connect Performance Center with REST API by browser/soap UI

Jump to solution

Hi Eyal,

Thanks for your comments,

Yes, i'm sending the url request to PC host only and on fiddler also i'm getting same error.

Due to security constarints can't update the snapshot of fiddler.

 

Regards,

Mohan

 

 

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Unable to connect Performance Center with REST API by browser/soap UI

Jump to solution

Resolved...Thanks every one.

The issue was with my attribute formats that i have used to send along with the request. Now successfully logged on to PC through REST API.

 

Regards,

Mohan

View solution in original post

0 Likes
Highlighted
New Member.

Re: Unable to connect Performance Center with REST API by browser/soap UI

Jump to solution

Hi Mohan

I am also facing the saem issue, Can you please help how did you solove the issue

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.