Highlighted
Trusted Contributor.
Trusted Contributor.
1070 views

Unable to replay Sharepoint script recorded in LR 9.52

Jump to solution

Hi,

 

I have recorded a LR (HTTP/HTML) script on Sharepoint.
While replaying I am getting the error message "system.Net.webexception: the request failed with HTTP status 401: unauthorized".
But I have already given user id and password in the function web_set_user in the below format.

web_set_user("Username",

        lr_decrypt("4042e3e7c8bbbcfde0f737f91f"),

        "Port:8080");

But still the script is failing at the first web_url.

Manually I can still log in to Sharepoint.

Should i do any correlation or anything else i am missing?

Please advise if you have had such similar issue or have any suggestion for solution.

Thanks,
Sindhu

0 Likes
1 Solution

Accepted Solutions
Highlighted
Trusted Contributor.
Trusted Contributor.

Re: Unable to replay Sharepoint script recorded in LR 9.52

Jump to solution

Solved.

I changed the Run time settings.

Runtime setting -> Internet protocol->perference , check WinINet replay instead of sockets

View solution in original post

0 Likes
3 Replies
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Unable to replay Sharepoint script recorded in LR 9.52

Jump to solution
Hi Sindhu,

The way you have kept web_set_user() function is wrong. Refer Functional reference guide examples for clear understanding. It should be like below.

web_set_user("Google\\ABCD", lr_decrypt("4042e3e7c8bbbcfde0f737f91f"), "sharepoint.xyz.com:8080");

Here the user "ABCD" is a AD user of domain "Google" and the target sharepoint Host or URL you are accessing is "sharepoint.xyz.com" running on port "8080".

Hope this helps you.

Regards,
Raj

Like this Post? Click Kudos! to show appreciation.
Is your issue addressed? Click "ACCEPT AS SOLUTION" against the post which helped you the most.
0 Likes
Highlighted
Trusted Contributor.
Trusted Contributor.

Re: Unable to replay Sharepoint script recorded in LR 9.52

Jump to solution

Hi Raj,

 

Thanks for the reply.

I have written correct web_set_user() in the script. While posting the question here i made a mistake in the syntax.

Any other probable solution?

 

Regards,

Sindhu

0 Likes
Highlighted
Trusted Contributor.
Trusted Contributor.

Re: Unable to replay Sharepoint script recorded in LR 9.52

Jump to solution

Solved.

I changed the Run time settings.

Runtime setting -> Internet protocol->perference , check WinINet replay instead of sockets

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.