Highlighted
Absent Member.. Absent Member..
Absent Member..
1783 views

VuGen / Citrix question : Unable to record Citrix part of multi protocol script

hello bac board

i know this has been discussed a few times bofore. i have used the search to look for older posts about this topic. but unfortunately i was unable to solve my issue by following the instructions in these post.

i'm trying to create script for Citrix / ICA. I would like to create a multi protocol script (HTTP/ICA). It's supposed to open the portal web page, log in with a user, start an application (Desktop), close the very same application, and log off from the portal page.

what happens is that i can record the HTTP part. but nothing is being recorded to the script about the citrix part (ctrx_).

i'm using the following versions:

Citrix client 9.0
Vugen 9.10

I have used the very same combination for a different environement some weeks ago where it has worked without any problem. so i assume there has to be some settings which are not correct in my case.

any help from you guys is much appreciated. points will be awarded

many thanks
0 Likes
6 Replies
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: VuGen / Citrix question : Unable to record Citrix part of multi protocol script

i just tried to record only the Citrix (ICA) part with selecting the.ica file.
i'm getting a "Protocol Driver error" when i try to do this.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: VuGen / Citrix question : Unable to record Citrix part of multi protocol script

Hi,

Has you mentioned that trying to record the script using .ica protocol. Is manually you are able to open the .ica file is it working? can you browse the citrix application manullay on the machine. It seems there is issue Citrix client on the machine check with citrix administrator and get it verified.

Download the ica file on your local machine and try to open. let us know if it working or not
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: VuGen / Citrix question : Unable to record Citrix part of multi protocol script

hello arvind and thanks for your reply

i connect to the application by using the web page (portal). when i record the script the .ica files is being dowloaded to a temporary location of the machine i'm using.
i have tried to record a simple ICA script by using this .ica file which has been downloaded. but when i try to start i'm getting a error message that the [ApplicationServers] configuration part in the ica. file is missing. i guess because i connect via the portal this information is not in the .ica file.

i can open and connect to the application from the very same machine when i'm doing it manually. also during recording there is no problem. the only thing is that there is no ctrx_ code being added to the script.
i'm using a VMWare based PC for this. not sure if this can have any impact. although i have scripted HTTP/S, RTE and WinSocked from the very same machine without any problem before. so i'd say that should not be a issue.

i have tried to use different version of the Citrix client. right now i have 9.0 installed. but i have tried version 10 with the registry fix/patch. and it was the same problem.

when i'm browsing the portal page ... is it possible to get the .ica file from there?
is it possible that the communication is encrypted somehow?

thanks for your help !!!
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: VuGen / Citrix question : Unable to record Citrix part of multi protocol script

I think the citrix client version is not supported , try using citrix 10.0, and also update the windows registry if required.

it should resolve your issue.
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: VuGen / Citrix question : Unable to record Citrix part of multi protocol script

Hello,

I also never succeeded to record Citrix part of multi protocol script (only http) 😞

Instead I wrote a webscript that downloads and saves the .ica from the body of the nfuse page that opens after the Application Icon.

I recomend Citrix ICA Client 9.x

I heared VuGen 9.5 has new capabilities to handle CITRIX nfuse...

Regards
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: VuGen / Citrix question : Unable to record Citrix part of multi protocol script

thanks for the comments folks

the reason why i was not able to record the citrix stream was that the portal URL was pointing to a server using SSH encrypted traffic. so clearly with this vugen was not able to pick up any part of the citrix stream.

beside that there is the regular citirx client/vugen version mixup. finally working with 9.x citrix client
but as mentioned by other 10.x version should be fine with the patch. although i have not tired it.

thanks again for the help
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.