Highlighted
Absent Member.
Absent Member.
3675 views

VuGen hangs and not launching the browser during recording

Hi,

Iam trying to record a HTTPS site. I'm using Web(HTTP/HTML) protocol and VuGen 9.1 for doing this.

After starting the process of recording following happens:
VuGen continues to work for ever without launching the browser.

I tried to record GOOGLE site for a sample HTTP recording. Irrespective of any URL, the same happens.

Note:
I can manually launch HTTPS website without any issues.

This is quite urgent for my project execution. Can anyone please help me solving this issue?

Regards,
Padma.
0 Likes
9 Replies
Highlighted
Absent Member.
Absent Member.

Re: VuGen hangs and not launching the browser during recording

Hi Padma,

To solve this go to Task Manager and search for the "iexplore.exe" in Processes tab and then stop that process by clicking End Process button. Similarly stop all the iexplore.exe processes which are running.

Do the same for vugen also. Search for "vugen.exe" in task mngr and stop that process also.

Then logoff from the computer and then login and start recording.It will work.

The only thing is do not open any web browser when you start recording.

Even after this if it doesn't work let me know the exact error.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: VuGen hangs and not launching the browser during recording

Close all the browser windows which are open and try, it should work
Donot open any browser while recording

Regards,
Sunkara
http://loadrunner95.blogspot.com/
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: VuGen hangs and not launching the browser during recording

I tried doing what you both have told me. Nothing works.

However, I could record successfully once. But when I tried immediately the next time, again the same problem.

In fact, I have shut down all the other applications while recording. Only VuGen was open for recording.

Can you now suggest why this happens? Am very confused with such a behaviour of VuGen.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: VuGen hangs and not launching the browser during recording

Hi Padma,

Yes it will work for first time when you do like that and second time it is not working because there is an iexplore.exe process which is running so again end that process and start recording.

So whenever you want to do recording, stop all the iexplore.exe & vugen.exe processes and then close the vugen and then again open vugen and start recording.

Note:Stop the process by right clicking that process and select End process tree.

Hope it will work.

While replaying it will not cause any problem,it will replay and launch the browser also. So just record properly and then you can customize it & replay without any issue.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: VuGen hangs and not launching the browser during recording

whats OS?
any antivirus running?
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: VuGen hangs and not launching the browser during recording

Hi Anuj,

I tried to record the script again after successfully recording it once only with all the process shut down (including vugen.exe and iexplorer.exe). But its not working either.

Hi Shiva,

OS is Windows XP SP3 and yes McAfee is installed and running in my machine.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: VuGen hangs and not launching the browser during recording

Hi Padma,

McAfee is the culprit here.

try to disable Host Intrusion Prevention Service (HIPS) feature and it should work.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: VuGen hangs and not launching the browser during recording

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: VuGen hangs and not launching the browser during recording

Hi Padma,

If it's not working then add iexplore.exe in DEP and try again.
Even after that if it doesn't work then re-install Loadrunner.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.