Highlighted
Acclaimed Contributor.
Acclaimed Contributor.
2804 views

authentication issue while scripting in vugen 9.10

Hi experts,

I am recording one application in vugen 9.10 while login into application it is asking for enter network password i enter there but script is not recording ..

So i write web_set_user function manually but in replay it is showing web_set_user sucessful and throwing exception..attached here is the replay log also find the login screen and scripts..

Also find the generation logs attached.it is showing "HTTP Error 401.2 - Unauthorized: Access is denied due to server configuration.
Internet Information Services (IIS)"


pls suggest..

Points will be awarded..

Thanks
Cheers!

Nvr Blame a day in ur life....... Good day gives "happiness" & Bad day gives "experience" ......
0 Likes
21 Replies
Highlighted
Frequent Contributor.. Frequent Contributor..
Frequent Contributor..

Re: authentication issue while scripting in vugen 9.10

Are you getting this popup while accessing the application manually also ? After seeing your generation logs the authentication scheme used is "Digest" . To furthur troubleshoot the issue try adding your server entry in port mapping with transport set to HTTP and rest all set to Auto. Apart from it also playback your scripts in extended log with all the three options checked and upload the same.

Let me know if you face any issues in carrying out the above steps

Regards,
Imran
You are resource limited only by your imagination
0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: authentication issue while scripting in vugen 9.10


Hey Imran,

Thanks for the reply..yes i am getting popup manually while login into application..
as discuused with application team the authentication used is Digest..

I haved added the entry in port mapping also with http service ID.but still it is giving authorization error..

Develpoer had assign basic authentication to my user id for time being and script working fine in such case..

but for digest authentication it fails..

Is vugen support digest authentication??How to handle with digest authentication

pls suggest

help will be really apperciated..

Thanks
Cheers!

Nvr Blame a day in ur life....... Good day gives "happiness" & Bad day gives "experience" ......
0 Likes
Highlighted
Frequent Contributor.. Frequent Contributor..
Frequent Contributor..

Re: authentication issue while scripting in vugen 9.10

Hi Parkar,

Loadrunner supports digest authentication but due to some reason its unable to include web_set_user(...) automatically in script.

Make sure your web_set_user is first line in the script

Try recording the script using just wininet and replay the same using wininet engine which can be done through run time settings by checking play using wininet

Or Just replay the existing script with wininet.

If you still face the issue upload the full replay log with all three options checked


Regards,
Imran

You are resource limited only by your imagination
0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: authentication issue while scripting in vugen 9.10

Hi Imran,

still it is giving me the same error.

pls suggest

Thanks,
Cheers!

Nvr Blame a day in ur life....... Good day gives "happiness" & Bad day gives "experience" ......
0 Likes
Highlighted
Frequent Contributor.. Frequent Contributor..
Frequent Contributor..

Re: authentication issue while scripting in vugen 9.10

Can you upload the detailed output/reply log as the 1 you have uploaded is a deafult one with not much details? Replay your scripts with exteneded log and all the three option checked and upload the same here.

Also make sure the authentication server name and port is set right in web_set_user(....)


web_set_user("icicibankltd.com\\uid",
lr_decrypt("cjwfwflskddefk24"),
"10.16.114.208:80");

In the above funtion, Is "icicibankltd.com" a domain name to which your uid belongs or its your computer name? and are you sure that your authentication server is same as the one on which your application is hosted.

Regards,
Imran
You are resource limited only by your imagination
0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: authentication issue while scripting in vugen 9.10

Dear Arman,

Thanks for the reply

It is valid for basic authentication it means there is nothing wrong in web_set_user function

For message authentication it is throwing exceptions

i will upload the script as you wanted..lets see if it helps you much in solving

thanks
Cheers!

Nvr Blame a day in ur life....... Good day gives "happiness" & Bad day gives "experience" ......
0 Likes
Highlighted
Frequent Contributor.. Frequent Contributor..
Frequent Contributor..

Re: authentication issue while scripting in vugen 9.10

Atleast take my name right its Imran not Arman.....
You are resource limited only by your imagination
0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: authentication issue while scripting in vugen 9.10

Ok Imran,

Pls find the attached scripts as per your requirement

pls suggest

Thanks
Cheers!

Nvr Blame a day in ur life....... Good day gives "happiness" & Bad day gives "experience" ......
0 Likes
Highlighted
Frequent Contributor.. Frequent Contributor..
Frequent Contributor..

Re: authentication issue while scripting in vugen 9.10

I went through your output log and found that the script was still played using socket replay engine.

However I would want you to try couple of more actions in addtion to winint

1)enable UTF-8 char support
2)Play your script with browser emulation and select IE and the browser version which you currently have in your system. (Make sure winit is unchecked when you try this option)Also bypass the proxy while accessing your site through loadrunner as proxies also interfere and creates problem in authentication.

In other words try a IE Agent instead of custom one which is (Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR )

I hope this resolves the issue

Regards,
Imran

You are resource limited only by your imagination
0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: authentication issue while scripting in vugen 9.10

how to enable utf-8 char support?

i will send the script soon.

Thanks
Cheers!

Nvr Blame a day in ur life....... Good day gives "happiness" & Bad day gives "experience" ......
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: authentication issue while scripting in vugen 9.10

Hi ,

Use LoadRunner 9.5 , sometimes LR 9.1 throws error with web_set_user. Recently I had faced same issues later it got solved by using LR9.5.

Regards,
Vinutha
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.