Highlighted
Absent Member.
Absent Member.
151 views

extremely slow response time when recording script via a direct connection using LoadRunner

Hi, I recently started working in LoadRunner 9.0, and I usually record scripts using a proxy connection. But recently I was asked to test the site using a direct connection. I've changed the proxy settings to No-proxy in run-time settings.

But now when I try to record the script, the website takes a very long time to load. When the site is simply browsed with no proxy settings it loads quickly. What seems to be the issue here? Do I need to change any other settings in LR?

FYI:
Protocol:HTTPS
Browser: IE

Thanks in Advance,
0 Likes
4 Replies
Highlighted
Absent Member.
Absent Member.

Re: extremely slow response time when recording script via a direct connection using LoadRunner

Your understanding of the proxy setting is wrong. Run-time setting proxy settings are used while replay of the script and not during recording of the script. So your thought that your change in run-time setting is affecting your recording is incorrect.

I would suggest you to record the same way as you used to do it before with the proxy and then later save the script with the run-time setting of no proxy. Now if you run your script, the script will emulate a user with no proxy setting in the browser which will satisfy your conditions.

Thanks
Prashanth Thimmavajjala
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: extremely slow response time when recording script via a direct connection using LoadRunner

Let me rephrase the question(I guess I was not clear enough previously).

I'm assigned to test an internal site at work. I'm able to access the site and record the script using LR - IE(with proxy settings).

But when I try to record this site in a PC which has a direct connection to the internet(No proxy set in IE) the website response time is extremely slow BUT when the site is randomly browsed it loads quickly.

What may be causing the slow response time in the website when the script is being recorded using LR?

Thanks,
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: extremely slow response time when recording script via a direct connection using LoadRunner

Hi,

some sites behaves like that while recording not sure they behaves slow during recording.

While replying script you will not see this slowness. Did you see same kind of response while replaying script also?

Thanks
Ravi
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: extremely slow response time when recording script via a direct connection using LoadRunner

Yes, the slowness was encountered on both occasions.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.