Highlighted
Absent Member.
Absent Member.
362 views

loadrunner rdp - won't connect

Hi,
I've got windows xp sp3, running loadrunner 9.51.

I've tried turning off DEP and alternatively, excluding the Remote Desktop connection and wmi performance adapter from DEP

When I try to use the RDP protocol in a script, I get the remote desktop windows with the connecting to message, but never does it come back.
I can try this side by side NOT using loadrunner and I DO get a connection.
I've tried a few different switches under vugen (including the default), but with the same result. I've tried a VM and physical machine with the same results. In either case, I get either 13 or 14 events listed when I try recording, but as I never get to a login screen, I can't proceed.

I'd appreciate any ideas or pointers.
carl
0 Likes
2 Replies
Highlighted
Absent Member.
Absent Member.

Re: loadrunner rdp - won't connect

Try this: When you start recording enter Default.rdp file in recording options and before start recording change "compression:i:1" to compression:i:0" and save the .rdp file. Use this and try.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: loadrunner rdp - won't connect

Looks like the newer versions of RDP don't have the option for compression, but turning off bitmaps got me further. I have to check synchronization now as the replay didn't work, but I've connected and recorded in my test case.
thank you.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.