Highlighted
New Member.
1201 views

"Host's installation is invalid"

"com.mercury.td.pcextension.labservice.comm.ILabServiceSetHostPCServiceExceptionDataFaultFaultMessage: Host's installation is invalid"

Getting this above error while adding new host to HP PC. How get out of this.

Followed all these below procedure.

1. Reinstalled PC HOST software

2. Confirm that all the 4 services are up and running.

  • Performance Center Load Testing Service
  • Performance Center Agent Service
  • Remote Management Agent Service
  • Data Collection Agent

3. IIS service is stopped using cmd (IISRESET/STOP)

4. Firewall is disabled. in the host machine

5. Logged in using IUSR_METRO and check that I am able to connect to ALM Server through IE browser.

6. Check ports 8731, 54345, 54245 are listening (using command: netstat -an)

7. Lastly uninstall PC HOST software and Install  and gave a restart to machine.

Still not able to find out what is the issue.
Solution for this will be much appreciated. Using HP PC 12.01 Version.

0 Likes
4 Replies
Highlighted
Contributor.. Contributor..
Contributor..

Re: "Host's installation is invalid"

I have this same issue now with the latest upgrade to 12.53. 

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: "Host's installation is invalid"

Two points that I have to check also

* Run the configuration wizard "As Administrator", without errors.

* Make sure UAC is disabled. On our servers it is restored again after some time

br /ola


Please mark post as solved if your problems or questions is/are resolved.
If this post was valuable to you, please consider kudo it.

.
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: "Host's installation is invalid"

Have you given correct passpharse, we are faced this issue when we given the other environment phasephrase.

You can see the correct valid passphrase in Site Admin, or get it from Vendor itself. Thanks.

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: "Host's installation is invalid"

Try adding the Host with the IP rather the Host Name.

& make the Host Entry for this in the Host in the below location:

C:\Windows\System32\drivers\etc\hosts file

After all these, add the HOST

 

(If this helped, accept as solution )
(Posts and opinions made here are my own and do not reflect the opinions of my employer)
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.