Highlighted
New Member.
128 views

recording Issue - SSL Hankshake Failed

Hello Guys,

Im recording an web application which has security alert before it direct to login page.

Manually when i check its working fine but while recording "Page cannot be displayed" error is displayed.

In log Im getting "Connection terminated - SSL Handshake failed"

Could anyone assit me to resolve the above issue.

Thanks in advance
0 Likes
3 Replies
Highlighted
Absent Member.
Absent Member.

Re: recording Issue - SSL Hankshake Failed

Change your Port Mapping settings in your Vugen Recording options. Change the capture level to "WinIlet level data" and try recording it.

Thanks
Prashanth T
0 Likes
Highlighted
New Member.

Re: recording Issue - SSL Hankshake Failed

thanks Prashanth for your correct and quicker response.

Now i could able to record the events

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: recording Issue - SSL Hankshake Failed

HI,

Add the server name in the port mapping under Network in the recording options,

enter the servername and the port usually 443 and choose the service as http and select the connection as proxy, ssl version automatic and click on Test SSL, first time it may not negotiate try Test SSL more than 2 times. It should successfully negotiate. After this record the script again
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.