Highlighted
Valued Contributor.
Valued Contributor.
11450 views

-27774: SSL protocol error when attempting to connect with host

Jump to solution

Hi Team,

Can some one help me in resolving the below error :

 -27774: SSL protocol error when attempting to connect with host

Tried  adding different functions along with web_set_sockets_option("SSL_VERSION", "TLS");

still issue not resolved.

Is there any work around for this error.

 

Regards

Raghavendra

 

0 Likes
1 Solution

Accepted Solutions
Highlighted
Valued Contributor.
Valued Contributor.

Re: -27774: SSL protocol error when attempting to connect with host

Jump to solution

Issue is resolved :

Solution : check box should be checked in runtime settings>>internet protocol>> preference>Advance tab- Use winlnet reply instead of sockets

View solution in original post

4 Replies
Highlighted
Honored Contributor.
Honored Contributor.

Re: -27774: SSL protocol error when attempting to connect with host

Jump to solution

Did you verify in the recording log which exact version and cipher were used during the recording?

 

0 Likes
Highlighted
Valued Contributor.
Valued Contributor.

Re: -27774: SSL protocol error when attempting to connect with host

Jump to solution

Hi

thanks for the reply.

i am using vugen 12.53 version.
- cipher version is "default openSsl Ciphers"(tried unchecking "enable auto ssl detection" also)

while recording i could see below error:
[Net An. Error    ( 10c: 5c0)] SSL_connect(ssl_id = 49797616 = 0000000002F7D9F0) Failed, ctx = 0000000002FEEBD0, err = "SSLv3 read server hello A", err code = 1
[Net An. Error    ( 10c: 5c0)]   (Sid:  3) SSL handshake with remote server Failed!

while replying:

Action.c(21): ssl_handle_status encounter error : SSL_ERROR_SSL, error message : error:1409442E:SSL routines:ssl3_read_bytes:tlsv1 alert protocol version   [MsgId: MMSG-26000]
Action.c(21): Error -27774: SSL protocol error when attempting to connect with host "XXXXX"   [MsgId: MERR-27774]

 

Regards

Raghavendra

0 Likes
Highlighted
Valued Contributor.
Valued Contributor.

Re: -27774: SSL protocol error when attempting to connect with host

Jump to solution

Issue is resolved :

Solution : check box should be checked in runtime settings>>internet protocol>> preference>Advance tab- Use winlnet reply instead of sockets

View solution in original post

Highlighted
Respected Contributor.
Respected Contributor.

Re: -27774: SSL protocol error when attempting to connect with host

Jump to solution

I have had a similar situation with the SSL protocol error when connecting to a host. In my case, the web_set_sockets function was set to use TLS1.2 and I was replaying the Vugen script using sockets protocol. When I changed the run-time settings to use WININET protocol, the same Vugen script did NOT encounter this SSL protocol error.

While this run-time setting change fixes the Vugen replay issue, I thought using the WININET protocol for a load test using the Controller is not a good practice since the WININET protocol does not SCALE like the SOCKETS protocol can SCALE when using large numbers of users. On top of this, I thought I was told by Loadrunner Technical support multiple times that the SOCKETS protocol should be used in most cases since that is the protocol that was DESIGNED for the Controller software in order to appropriately scale for load tests with a large number of users (over 100).

Can someone provide the real answer to this question?

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.