Highlighted
New Member.
460 views

ACTION BLOCK SHOWING BLANK DURING SCRIPT RE-RUN IN TRUCLIENT

Hello Team,

I created a script using HP truclient. I have some test steps in "init block", some in "action block" and the remaining steps in "End block". However, during rerun, the test fails because when the init blocks finishes runing and the script moves to the next step in the action block, the web pane becomes blank. i.e. the last page that was loaded during the last step in the "init block" becomes blank, therefore the next element in the action block is not found.

please assisst.

N.B if i record all the steps (60 in all) in one action block, it runs successfully without any error.

0 Likes
1 Reply
Highlighted
Contributor.. Contributor..
Contributor..

Re: ACTION BLOCK SHOWING BLANK DURING SCRIPT RE-RUN IN TRUCLIENT

Hi,

Try recording into the Init block & when finished stop recording.  Then switch to the Action block & start recording again - the TruClient protocol will automatically insert a reload/navigate of the last page touched in the Init block - go on from there. 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.