Highlighted
Contributor.
Contributor.
513 views

Application Login Failure with VuGen/IE Browser - Path specified not Found

 Hi All,

I have developed a simple 5-step automated script that begins with logon, does some simple operations and logs out. I am running this script using HP TruClient with IE.

After the script has been run twice, the bowser fails to logon to our application in IE using the same machine. (Both using TruClient and even without TruClient being involved at all) It goes past the authentication and authorization steps but won’t transition to the landing page. Interestingly, chrome and FF logon works fine. When an alternate client machine is used to logon it works. When this state is reached, I can no longer use IE to logon to our application.

Clearing cache at the browser-level and restarting the laptop didn’t solve the problem. Once our application was reinstalled, I was able to logon to it using IE on this machine again. Unfortunately, there are no application logs capturing the details other than the IE developer tools that shows a "specified path not found" error.

I know this is probably an issue with our application, but I wanted to see if anyone has encountered something similar while we are working on it internally.

Thanks in advance.

0 Likes
5 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Application Login Failure with VuGen/IE Browser - Path specified not Found

Please open a support ticket.

Which version of LoadRunner do you use? Which OS are you experiencing the issue on?

0 Likes
Highlighted
Contributor.
Contributor.

Re: Application Login Failure with VuGen/IE Browser - Path specified not Found

LR 12.5 with Windows 10

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Application Login Failure with VuGen/IE Browser - Path specified not Found

I assume you meant 12.53 or 12.55, right? 12.50 didn't support Chromium yet.

Would be great if you can validate it on Windows 2012 machine. I would like to see if the issue is OS related. Latest editions of Windows 10 had some changes in IE cache management - might be the cause.

0 Likes
Highlighted
Contributor.
Contributor.

Re: Application Login Failure with VuGen/IE Browser - Path specified not Found

Hi Shlomi,

I tried with 12.55 and 2008 and saw no issues. 12.55 with Windows 10 is the issue and we've narrowed it down to being a cookie issue. Is there a way to delete IE Browser cookies each iteration?

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Application Login Failure with VuGen/IE Browser - Path specified not Found

Thanks for the update. I suspected the issue is related to TruClient IE with Windows 10.

TruClient run time settings are configured to clean cache and cookies by default between iterations. This is applied by "Simulate a new user for each iteration" in the replay tab. If you unchecked it you can try adding an Evaluate JavaScript step at the beginning of the action and use Utils.clearCookies() function.

Regards,

Shlomi

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.