Highlighted
Absent Member.
Absent Member.
761 views

Authentication Issue while connecting to cloud app

Jump to solution

Hi All,

I am facting authentication issue while my app submitting credentials to external cloud app (integration).

The recording of the script is happening perfectly fine, but when I am trying to replay getting error before connecting to cloud.

 

Action.c(8): Error -26547: Authentication required, please use web_set_user, e.g. web_set_user("domain\\user", "password", "host:port");   [MsgId: MERR-26547]
Action.c(8): Error -26630: HTTP Status-Code=401 (Authorization Required)

p.s:  1. proxy autoconfiguration file is specified in Run-Time Settings, this will have any impact on web_set_user function ?

2. Web_set_user   username & password contain special character '@"  

I have already added the web_set_user in the script but am still getting the same error.

Any help on this is highly appreciable.

0 Likes
1 Solution

Accepted Solutions
Highlighted
Honored Contributor.
Honored Contributor.

Re: Authentication Issue while connecting to cloud app

Jump to solution

 

Yes you have to extract the CSRF Token  and use it in web_add_header.

Also check the LB and RB in the Code Generation log properly .Sometimes there also you will find issues with carriage return and new line addition. 

If you are not able to extract the value from code generation log , replay using "Data returned by server" for taking the correct LB and RB value.

Regards,

Raghul M

 

View solution in original post

0 Likes
5 Replies
Highlighted
Absent Member.
Absent Member.

Re: Authentication Issue while connecting to cloud app

Jump to solution

 authentication failed for web customer request (POST, application type::json) after redirect. 

any pointers please

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: Authentication Issue while connecting to cloud app

Jump to solution

Hi Srini,

Please check the failed request Snapshot-> Raw Data-> Request  and compare both recorded and replayed request. Also provide the same credential which you have used for web_set_ser  in custom proxy settings in Run Time settings 

Please let me know what type of authentication(NTLM, Basic and Kerbros) is implemented.

Regards,

Raghul M

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Authentication Issue while connecting to cloud app

Jump to solution

Hi Raghul,

application telechnology (Json) hosted in cloud . not sure about the authentication type. 

CSRF Token was generated in request header after connectivity established to cloud (recording).

but CSRF Token was not appeared in replay request header.

I need to add this using web_add_header? or any other pointers please.

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: Authentication Issue while connecting to cloud app

Jump to solution

 

Yes you have to extract the CSRF Token  and use it in web_add_header.

Also check the LB and RB in the Code Generation log properly .Sometimes there also you will find issues with carriage return and new line addition. 

If you are not able to extract the value from code generation log , replay using "Data returned by server" for taking the correct LB and RB value.

Regards,

Raghul M

 

View solution in original post

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Authentication Issue while connecting to cloud app

Jump to solution

Thanks Raghul issue resolved.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.