Highlighted
Visitor.
286 views

Avg response time Load runner Report vs Report from Apigee

 Hi, 

I recently ran some tests in production env and observed a huge difference in avg response time report generated from load runner compared to report generated from Apigee. I’m using web Http protocol (rest API/XML calls). We have two diff Data center in diff locations. My load generators are  in diff location and the endpoint I’m targeting is in diff location but I ran trace rt from  load generators  to other data center and latency is just 70 ms but response time diff is more than 10 sec. Test scenario --  protocol- web HTTP  users—2k .  Scenario-- Endpoints pointing to load runner in (datacenter A) – goes to ----- bigIp (datacenter B)--   Apigee (datacenter B)- ---- Target servers (datacenter B) and target server  send back the response to apigee. And from Bigip to apigee its just 0.2 ms.

In apigee we can generate the report in which avg response under load is below 2 to 3 secs. But in load runner report avg response time is more than 10 sec. I’m trying to find out why there is a huge difference between the response time from apigee and load runner.  Please let me know if there are any suggestions ...which I can try. Thanks in advance. 

Thanks

Sutanu

0 Likes
1 Reply
Highlighted
Super Contributor.
Super Contributor.

Betreff: Avg response time Load runner Report vs Report from Apigee

Hi Sutanu,

a few questions from to better understand your problem:

  1. Were the same high response times achieved when playing the script in vUGen?
  2. Did You minimize the runtime settings in the scenario?
    a) Internet protocol - Preferences
        - create snapshots
        - request zlib headers
        - Generate Web performance graphs (Hits per second and HTTP codes; Response bytes per seconds)
    b) Browser emulation
        - Simulate browser cache
        - Download non-HTML resources
        - Simulate a new user on each iteration
    These settings can increase the transaction response time in LoadRunner
  3. How many Loadgenerators are serving the 2k vUsers?
  4. Did You monitor the system performance counters for Loadgenerators?
    Did you notice any abnormalities (CPU, RAM, Network load)?

Regards, Christoph

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.