Highlighted
Absent Member.
Absent Member.
596 views

BPC 10 NetWeaver - Lr12 replay issue

Hi all,

 

I am having issues replaying a BPC script with LR12, I have recorded the flow with fiddler serveral times and created the script directly (right click on fiddler log) and using the BPC 10 Toolkit as well, getting the same requests.

 

When running the script it failed due to a 500 error, almost at the end of the script. The error message is:

"[{"code":"UJX_ERROR_003","description":"Invalid value <PACKAGE_GET_PROMPT_REQUEST xmlns=\\"http at offset 0 expecting null or { for data type \\\\TYPE=UJXD_S_PACKAGE_INFO","severity":"error","...

 

But one request before the response is not complete, it is only"[]"  instead of the proper table but the HTTP code is OK "200".

 

Do you know about any VuGen limitations with BPC 10 NetWeaver or any security settings that may be blocking the script to get into those processes?

 

 

Any comment or suggestion will be appreciated.

 

 

Thanks

Rene

0 Likes
5 Replies
Highlighted
Absent Member.
Absent Member.

Re: BPC 10 NetWeaver - Lr12 replay issue

Hi Rene,

Any chance you can attach your script and/or Fiddler log file?

Thanks!

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: BPC 10 NetWeaver - Lr12 replay issue

Hi 

 

Actually it seems like fiddler nor LR are not recording something, I have recorded the same process with LR proxy directly and I got the same code, it seems like we are not recording/replaying one or more methods.

 

do you know if this could be due to a server security setting?

 

Thanks

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: BPC 10 NetWeaver - Lr12 replay issue

So, it's a recording problem, not a replay problem? In that case, could you record your business process with WireShark and see whether the problematic steps make it into the resulting pcap?

You can send us the pcap and indicate which steps, which are recorded by WireShark, are not recorded by VuGen.

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: BPC 10 NetWeaver - Lr12 replay issue

Hello Rene,

Were you able to resolve the issue? I am using LR 12.55 and see the same error message. I tried with Fiddler and also did direct recording with LR , but still have same error.

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: BPC 10 NetWeaver - Lr12 replay issue

I was able to resolve this issue. Few headers were missing ,Added headers and script got executued sucessfully.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.