Absent Member.. Absent Member..
Absent Member..
541 views

Can't corretale.

Jump to solution

 

Hello everyone,

 

I'm trying to record a VUGen script for a web app that uses dynamic URLs (don't ask me why). The param i'm trying to correlate is this one (the text that looks like a key):

 

_message=&_action=A%3AHOLA+++++&_initial=6FFF6104B62829558A21A0355AA929348AA48437E4B1B29660189890A029AA5484A0A9D2A629A1549284A9D262969AD264989623641B98336E1A98836A961993701C99836C9919135A9899336A989A936C1A9CD26218182312149C2486A19C14601A21936A9B1B7352849C2486A19C14601A21936A9B1B73BA

 

The correlation i'm using is:

 

web_reg_save_param("Key", 
"LB=&_initial", 
"RB=", 
"Ord=1", 
"RelFrameId=1", 
"Search=Body", 
LAST);

web_submit_data("{Mon}.mon",
"Action=http://{UrlMonito}/monito/{UrlMon}.mon",
"Method=POST",
"RecContentType=text/html",
"Referer=http://{UrlMonito}/monito",
"Snapshot=t3.inf",
"Mode=HTML",
ITEMDATA,
"Name=_message", "Value=", ENDITEM,
"Name=_action", "Value=A:HOLA ", ENDITEM,
"Name=_initial", "Value={Key}", ENDITEM,
LAST);

 

I placed it before the call of that submit, however i always get:

 

Action.c(47): Error -26377: No match found for the requested parameter "URL2". Check whether the requested boundaries exist in the response data. Also, if the data you want to save exceeds 256 bytes, use web_set_max_html_param_len to increase the parameter size  	[MsgId: MERR-26377]

Action.c(47): Notify: Saving Parameter "URL2 = ".
Action.c(47): web_submit_data("{URL1}.mon") highest severity level was "ERROR", 3790 body bytes, 298 header bytes, 12 chunking overhead bytes [MsgId: MMSG-26387]

 Also, I tried to use 

 

web_set_max_html_param_len("1024"); 
web_set_max_html_param_len("2048");

Etc.

 

No results whatsoever. I don't know how to make it work, the BIG problem is the web app is only supported by IE (max v9), so, i can't use TruCient to avoid the correlations. Web (Click and Script) doesn't work either.

 

0 Likes
1 Solution

Accepted Solutions
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Can't corretale.

Jump to solution

Hello,

 

I ended up using LR 11.51 with TruClient IE. Had to upgrade the BPMs to 9.2X.

 

Regards.

View solution in original post

0 Likes
3 Replies
Highlighted
Absent Member.
Absent Member.

Re: Can't corretale.

Jump to solution

Hi,

It looks from the screenshot that you're using a very old LoadRunner version, which is no longer supported. Which version is it? The earliest supported version at the moment is 11.50, but i suggest upgrading to the latest and gratest, i.e. 12.02.

Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Can't corretale.

Jump to solution

Hello,

 

I ended up using LR 11.51 with TruClient IE. Had to upgrade the BPMs to 9.2X.

 

Regards.

View solution in original post

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Can't corretale.

Jump to solution

Hi,

 

Please note that the web_reg_save_param API looks for the value in the next response. In the code you attached, you are trying to register a web_reg_save_param parameter, and use it on the following request.

 

You should place the web_reg_save_param before the step that you get the dynamic value in the response, and then send it like you did in the web_submit_data step.

 

Thanks,

Yoav

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.