Highlighted
Absent Member.. Absent Member..
Absent Member..
586 views

Can't get VuGen Correlation Rule to work

I want to use Correlation Rules to speed up my scripting but hardly no one is working. The only working rule is a simple boundary based rule. My other rules with Regular expressions or JSON query are not working despite they work in the "Test mode" or if I add them manually afterwards. What can be my problem?

I am using LR 12.50.

0 Likes
10 Replies
Highlighted
Absent Member.
Absent Member.

Re: Can't get VuGen Correlation Rule to work

If the rules are working when applied manually, then what is the case, in which they're not working?

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Can't get VuGen Correlation Rule to work

I mean that the correlations are working if I add them manually. My problem is when trying to use the Correlation Rule feature.

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Can't get VuGen Correlation Rule to work

Please share your script and correlation rules (.cor file)
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Can't get VuGen Correlation Rule to work

I am not allowed to share that information due to my company security rules. But I can show you some screen shots.

1. Working rule

2. Non working rule

3. Succesful test of non working rule

4. Correlation Configuration

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Can't get VuGen Correlation Rule to work

Sorry, without a script and the rules we'll just be shooting in the dark.

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Can't get VuGen Correlation Rule to work

Ok, and you don't have any hints on what normally is wrong when a correlation rule fails?

0 Likes
Highlighted
Established Member..
Established Member..

Re: Can't get VuGen Correlation Rule to work

I would say in 5 from 10 cases are the rules are not correct. in 4 from 10 cases something is worong configured. and in one of 10 cases there is a bug in LR.  

Dose the check of the rule shows that it works?

Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Can't get VuGen Correlation Rule to work

I think you can see my screen shots in an earlier reply. Rule check is working.

0 Likes
Highlighted
Established Member..
Established Member..

Re: Can't get VuGen Correlation Rule to work

Hi,

Sorry i am not able to look the screenshots maybe a forums bug....

my suggestion is check the JSON is the Recording Options -> Advanced -> Non-Resources listed. By default is there only text/html and text/xml and when you want correlatate application/json it must be listet there.

Also check in the Recording Options Correlation -> Configuration the documentation "How to exclude content based on content-type... maybe there you need also an adjustment.

Best Regards,

Jürgen

Jürgen

0 Likes
Highlighted
Visitor.

Re: Can't get VuGen Correlation Rule to work

Hi ,

I had created around 20 rules ( Json calls) and when tested it works. After script is recorded in the Design Studio it identifies only few of them.

Also in the Non-Resource ,i had similar settings as mentioned.

Kindly let me know if any configuration to be done to have the complete Set of correlation rules applicable.

Vugen  12.56 build 0603

Attached the screenshots

Regards,

Sunil Kumar K

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.