Highlighted
Acclaimed Contributor.
Acclaimed Contributor.
1976 views

Command Line Interface (CLI) Tool to start the test - Not working

Jump to solution

I'm trying to start the load test using CLI tool available in 12.60. and getting below error. 

C:\Program Files (x86)\Micro Focus\LoadRunner\bin>CLIControllerApp.exe -InputFile C:\Users\km\Desktop\LR_CLI_Web.xml -CollateAndAnalyze -ResultName C:\Temp\CLI_Results
Controller did not start. Process returned error: 1326

Below is what I tried. 

<CliRun>
    <Groups>
        <Group>
            <Name>a1</Name>
            <Vusers>2</Vusers>
            <Script>
                <ID>1</ID>
                <Name>ReportDemo</Name>
                <Path>C:\Users\madanka\Documents\VuGen\Scripts\ReportDemo</Path>
            </Script>
            <ProtocolType>QTWeb</ProtocolType>
            <AssignedHosts>
                <HostName>localhost</HostName>
            </AssignedHosts>
        </Group>
    </Groups>
    <Hosts>
        <Host>
            <Name>localhost</Name>
            <Installation>Windows</Installation>
            <HostPurposes>
                <HostPurpose>Load Generator</HostPurpose>
                <HostPurpose>Controller</HostPurpose>
            </HostPurposes>
            <State>Ready</State>
            <Location>Local</Location>
            <ID>1</ID>
            <IsOverFirewall>false</IsOverFirewall>
        </Host>
    </Hosts>
    <Scheduler>
        <Name>Scheduler 1</Name>
        <Data>
            <Duration>120</Duration>
        </Data>
    </Scheduler>
</CliRun>

 

Labels (1)
Tags (1)
0 Likes
1 Solution

Accepted Solutions
Highlighted
Micro Focus Contributor
Micro Focus Contributor

Re: Command Line Interface (CLI) Tool to start the test - Not working

Jump to solution

Hi Madan,

See attached archive with the updated CLI tool. Also use the XML from inside the archive. Please send us an update if the new tool works as you expected.

If it works we will have an official release with the new version.

Calin

View solution in original post

0 Likes
10 Replies
Highlighted
Honored Contributor.
Honored Contributor.

Re: Command Line Interface (CLI) Tool to start the test - Not working

Jump to solution
0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Command Line Interface (CLI) Tool to start the test - Not working

Jump to solution

XML input for the CLI was prepared referring to the same link. In fact it is just copy of the example given with changes as per our environment.

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Command Line Interface (CLI) Tool to start the test - Not working

Jump to solution

Hi @KMadan,

From the error it seems like you didn't provide correct credentials for the CLI tool to run. Check Invoking the CLI Tool section. Did you follow that?

The credentials needs to be of an admin user that has a permission to install a service on the local machine.

Regards,
Shlomi

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Command Line Interface (CLI) Tool to start the test - Not working

Jump to solution

@Shlomi Nissim 

Yes, I did follow the document mentioned. 

Following is the conent modified in the LoadRunner\bin\CLIControllerApp.exe.config file for username/password. Is this correct way to mention the domain user credentials? The same user is used to install the LoadRunner and has admin permissions. 

<add key="UserName" value="domain1\user1" />
<add key="Password" value="pwdpwd" />
 
Regards,
Madan
0 Likes
Highlighted
Micro Focus Contributor
Micro Focus Contributor

Re: Command Line Interface (CLI) Tool to start the test - Not working

Jump to solution

Hi,

The correct syntax for the user name is:

<add key="UserName" value="user1" />

where user1 is an admin user on the Controller machine.

 

Regards,

Calin

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Command Line Interface (CLI) Tool to start the test - Not working

Jump to solution

Yes, I did try that way and received the same error. Is there any detailed logging available for this feature? 

~Madan

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Command Line Interface (CLI) Tool to start the test - Not working

Jump to solution

Hi Madan,

Can you send me in a private message your email address so we can send you a Skype invitation to have a look at your environment?


Adrian

Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Command Line Interface (CLI) Tool to start the test - Not working

Jump to solution

Hi Adrain, 

I have sent a private mesage few days back. Did you receive it? Let me know if you need any additional info to verify the issue. 

~Madan

0 Likes
Highlighted
Micro Focus Contributor
Micro Focus Contributor

Re: Command Line Interface (CLI) Tool to start the test - Not working

Jump to solution

Hi Madan,

See attached archive with the updated CLI tool. Also use the XML from inside the archive. Please send us an update if the new tool works as you expected.

If it works we will have an official release with the new version.

Calin

View solution in original post

0 Likes
Highlighted
Established Member..
Established Member..

Re: Command Line Interface (CLI) Tool to start the test - Not working

Jump to solution
Hi, Can you please share the updated CLI tool?
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.