Highlighted
Honored Contributor.
Honored Contributor.
1504 views

Controller--Load Generator connection weird issue after 12.53 patch3 upgrade

Hello Experts,

I know its sounds weired ,but i need your help/suggestion in fixing the issue.

We have three machines A  B& C. Machine A act as controller and  B& C act as load generator. I did full installation on machine A and installed agent ,Vugen and Analysis on Machine B and C.

We are using loadrunner v12.53 and yesterday i have updated to patch3 . Since them i am facing issue connecting controller and load generator.

On Machine B& C , when i install Load Generator Agent and set as process, connection between Controller (A) and Load Generator(B&C) works perfectly fine. Test is executed sucessfully.

But when i also install Vugen on Machine B&C along with Agent, controller and load generator is failing. From controller sceanrio, it shows "Failed to Connect load generator"

I followed below sequence in doing the patch upgrade:

1)On load generator machine i.e machine B & C, i have first installed Agent and then did patch upgrade.

2)After Agent upgrade, i installed Vugen and did patch upgrade.

Is this correct way of doing upgrade?

 

i checked and confirmed below things:

1)Agent is running on Load generator machines

2)No Firewalls enabled

3)Port 54345 is open

4)Ping works bidirectional .

 

Please advise and help fixing the issue.

 

0 Likes
6 Replies
Highlighted
Frequent Contributor.
Frequent Contributor.

Re: Controller--Load Generator connection weird issue after 12.53 patch3 upgrade

 

Hello,

So my first thought is you have to update your controller machine to the same version.

is this step missed? 

Regards,

Bingle(LoadRunner R&D)

 

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: Controller--Load Generator connection weird issue after 12.53 patch3 upgrade

Hello,

Yes, i have correct controller patch. Does squence of upgrade will have any impact ? like installating lg patch then doing vgen patch?

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Controller--Load Generator connection weird issue after 12.53 patch3 upgrade

Hi Nik,

While we do not prevent installing VuGen and Load Generator on the same machine this combination is not recommended by us. It is stated in LoadRunner Product Availability Matrix 

Having said that if you do use this option I suggest installing GA version first of both/all components and then install the respective patch for each. That would be the correct sequence. If it does not work I suggest working on a separate machine for VuGen and Load Generator. Analysis can be installed in either one of them.

Regards,

Shlomi

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: Controller--Load Generator connection weird issue after 12.53 patch3 upgrade

Hello Shlomi,

Thanks for the reply. I did try installing GA version and then installing patch. I am facing same issue.

Before patch upgrade, i had LG agent and Vugen on same machine and it worked fine. If i don't do patch upgrade it works fine. But when i upgrade to patch 3 issue occurs.

 

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Controller--Load Generator connection weird issue after 12.53 patch3 upgrade

Hi Nik,

As an immediate workaround I suggest installing LG and VuGen on separate machines.

For further troubleshooting please open a support ticket. If I am not mistaken you purchased the product via SAP. Please work with to sort the support channel. It is important you will have that available for you.

For immediate additional troubleshooting, I suggest checking that the LoadRunner agent is running, if it does open its' log and share here the log content. Check the path from which this agent is running from and make sure it is the Load Generator path and if it isn't close the agent and go to the Load Generator home directory\\launch_service\bin adn then run magentproc.exe

Finally, I would suggest installing VuGen and then Load Generator GA version. Then VuGen patch and LG patch.

Try to keep the LG last.

Good luck

Shlomi

 

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: Controller--Load Generator connection weird issue after 12.53 patch3 upgrade

Hello Shlmoi,

Thanks for the reply. I will follow your suggestion and keep you posted.

If i am not wrong, we need to install Load generator first and then Vugen. If i install Vugen first and then Load generator, it pops up message to uninstall Vugen.

I will keep you posted further on this.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.