Admiral Admiral
Admiral
376 views

Controller: no data collected

Hi all, 

I've a problem with a script recorded with TruClient (IE). The script, and so the navigation, goes well in VuGen and in Controller too, but if I use localhost as generator. 

On the contrary, if I set a certain remote computer as generator, Controller doesn't collect anything: duration continues, but no one transaction will be count. 

I had a similar problem some times ago, and I resolve it by changing the language settings from the generator remote machine: this time this procedure doesn't work. 

Can anyone advise me some suggestion?

Thanks in advance, 

Lorenzo

0 Likes
6 Replies
Micro Focus Contributor
Micro Focus Contributor

Hello

Are you using different locales on the Controller and Load Generator machine? Also, do you experience the same issue with the same setup but running a Web script?

Can you give more details regarding what is happening during the run? Do you see the vusers being initialized, do you see errors?

Regards,

Sinziana

Admiral Admiral
Admiral

I Sinziana, 

thanks for your reply. I use external computers as load generators (for our scopes, we use localhost as generator only when expected transactions are low, with few users or brief duration of scenario) and, until now, I had see this situation only with TruClient. 

As I wrote before, other times I've fix the issue by changing language settings from the generator computers, forcing "English (United States)" as primary system language. 

During the run, users go in the "Run" column, but no data is collected: duration continues, but graphs and transaction rows still empty. No errors are reported.

Thanks in advance for any type of suggestion, 

Lorenzo

0 Likes
Admiral Admiral
Admiral

Hi all, 

does anyone have news about the reported problem? 

In few words, I have a TruClient-Firefox script: its execution goes well in VuGen and with Controller only if I use localhost as generator; instead Controller doesn't collect data from other external generators. I add that we always use those external generators for other TruClient's scripts, but this time no data is collected. I tried to change language format, with no results. 

Can anyone help me about this issue?

Thanks very very much in advance,

Lorenzo

0 Likes
Lieutenant
Lieutenant

Same issues here!

 

Did you have any solution?

 

After we are done with a test using localhost and a few servers as loadgenerators, retreiving data gives an error. Not all data is collected and only the summary is fine.

 

Any ideas?

 

Thanks!

0 Likes
Admiral Admiral
Admiral

Hi all, 

I have again the same problem: I have a script that goes well from VuGen and from Controller if I use localhost as load generator. But if I use a pool of load generators (external machines, that we use always for our massive tests) Controller doesn't collect data or metrics, as you can see in the image below. 

ControllerNoMetrics.JPG

The error message that appear says: "Error -205177: ** 2: Navigate to https://....com/ ** timed out"

Can anyone help me with this terrible matter?

Thanks a lot!

Lorenzo

LoadRunner version: 12.53 - Script: TruClient IE - Load generator machines OS: Windows 10 - Localhost OS: Windows 10

Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Hi Lorenzo,

Sorry for this issue bothering you so long time.

According to your description, I have the following suggestions: make sure the remoted load generator machines connection, network status and administrator rights. If the issue still exist, could you please provide more error logs?

Regards,

Renber

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.