Highlighted
Senior Member.
173 views

Discrepancy observed between Transaction response time through LR and Manual time on browser(Chrome)

Hi,

I have gone through several threads on the forum but have been unable to understand discrepancy in Transaction response times for my script with single user. My script is based on Http/Html protocol and I am using LR 12.53. Currently, a simple operation (such as login) is taking 15s manually through browser (chrome), but the same is taking over 2 mins through the tool. The script has been executed through Vugen as well as through Controller (6 iterations and separate Load generator machine). I have tried the following tweaks to my script:

  1. Tried running the script through browser as well as Custom Agent string
  2. Tried the script with and without browser cache settings.
  3. Ran the script with and without logs.
  4. Removed Extrares from the script.
  5. Correlated and parameterized all possible values (including timestamps)

It is due to this anomaly that I am unable to guarantee an accurate response time for multiple users for my script to management when a simple action like login is giving inflated timings.

 

Request you to please provide suggestions for same and let me know in case I missed something.

Thanks,

Aditi Arora

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.