Highlighted
Established Member..
Established Member..
102 views

Does LG required to maintain Browser version, which we defined in Runtime settings-User Agent

Hi,

The application which we testing required I.E 11v, So we modified the runtime setting-user agent accordingly, Using 11.05version.
The script is passed thoug we are not changing the user agen, since the application required updated borswer version, we have been changed, script is passed post changing

Question: Our load generator is also 11.05v(another machine), So do we required to maintain the same version of browser-I.E 11v in Load generator machine?

Kindly help with the answer/explanation how the user agent and load generator borwser works.


Requesting help at the earliest as we need to finish the activities with in the timelines.


Regards,
Kishore

0 Likes
2 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Does LG required to maintain Browser version, which we defined in Runtime settings-User Agent

Hello Kishore,

Thank you for your message.

About this, If you are using a web protocol script, the IE version is not going to affect on the execution of the test.

The browser emultation what does is to emulate another version of IE different from the one that was recorded originally.

 

So, if your script was recorded on IE 10, and on your LG you have IE 11, there is not going to have big problems.

Now, if the script was recorded on IE 9, and your LG have IE 11, but you want to know how it behaves on IE 10, you can only change the browser emulation settings.

All of this is going to depend on your needs.

I hope, this information clarify your concerns, however for more information about the browser emulation, you can check the LoadRunner Userguide on chapter "Browser Emulation - Overview"

 

Regards,

Daniela Gómez Alvarado
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
Highlighted
Established Member..
Established Member..

Re: Does LG required to maintain Browser version, which we defined in Runtime settings-User Agent

Enter a bodyHi,

 

Thanks for your reply.

 

T

Hi,

 

Thank you so much for your help.

 

From the above reqply, wehat my understandng is: what ever be the Broswser in LG, We can manage the script by mentioning the required user agen in borwser emulaton.

This will help with our required resultlts.

 

Please correct me if any thing wrong.

 

Regards,

Kishore Y

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.