Absent Member.
Absent Member.

Error -26630: HTTP Status-Code=401 (Unauthorized)

Hi All,

I am recording an application in Vugen 12.53with Web http/html protocol. When i replay the script I see the error HTTP Status code = 401 (Unauthorized). I have tried multiple options as listed below, none of the solutions worked for me. Please kindly help me.

1. Recorded script in web http/html and oracle web protocol, and also tried with htmll and URL mode.

2. Added web_Set_user(user id, pwd, host);

3. Used web_Set_sockets option

4. Correlated the dynamically generated Security Token.

5. Tried replay in winlnet replay instead of sockets

6. And i have checked that my application is not using Kerberos Autentication.


Please let us know what else can be done to resolve this issue.

1 Reply
Frequent Contributor.
Frequent Contributor.


401 means the server requires authentication but failed.

You should turn on extended log and check in the replay log:

The “WWW-Authenticate:” header in server to client response indicate which kind of Authorization the server requires.

And the “Authorization:” header in client to server request contains Authorization data.  

This will show you direction on what’s going wrong.

Then you can try the options in “RTS->Internet Protocol->Preference-> Authentication” to see whether it could solve the issue 


Bingle(LoadRunner R&D)

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.