Highlighted
Absent Member.
Absent Member.
5643 views

Error -27774: Server " shut connection during attempt to negotiate SSL session

0 Likes
6 Replies
Highlighted
Absent Member.
Absent Member.

Re: Error -27774: Server " shut connection during attempt to negotiate SSL session

Hi Rupanjana,

Please add this code at the beginning and try 

web_set_sockets_option("SSL_VERSION", "TLS");

If still didnt work then change WININET in Run time settings

 

 

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Error -27774: Server " shut connection during attempt to negotiate SSL session

Hi,

Correct me if I am wrong but WININET is only available in Recording Options not in Run time settings

0 Likes
Highlighted
Contributor.
Contributor.

Re: Error -27774: Server " shut connection during attempt to negotiate SSL

Just a slight addition, but I ran across this and this was basically the fix, but I had to declare the version of TLS to use like so -  web_set_sockets_option("SSL_VERSION", "TLS1.2");

The thing that was odd was that even though the script playback worked from a Windows 2012 server with TLS1.1, it did not from a Windows 2008 server. I had to set the TLS version to 1.2 to get this the playback to work from both servers.

Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: Error -27774: Server " shut connection during attempt to negotiate SSL

In addition, the inclusion of the command web_set_sockets_option("SSL_VERSION", "TLS"); also can resolves the error message Error -27778 : SSL protocol error when attempting to read with host

Lorenzo 

0 Likes
Highlighted
Respected Contributor.
Respected Contributor.

Re: Error -27774: Server " shut connection during attempt to negotiate SSL session

Hello Rupanjana,

You can try below steps,

  1. Limit the number of connections open from the client to the server by using, web_set_sockets_option("MAX_CONNECTIONS_PER_HOST","1");
  2. web_set_sockets_option("SSL_VERSION", "TLS1.2"); 
    This forces the connection to the server to a particular protocol rather than letting the server suggest one during the connection handshake.
  3. If none of the above helps, then use the WinInet Replay engine. To do so, go to Run-Time Settings -> Preferences -> Select "WinInet Replay Engine instead of Sockets (Windows Only)."

If this resolves your issue give Kudos & accept as solution.

Highlighted
Super Contributor.
Super Contributor.

Re: Error -27774: Server " shut connection during attempt to negotiate SSL

It happened to me on Single Transaction scripts so I neded to add web_set_sockets_option("SSL_VERSION", "TLS1.2");

Now it works fine.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.