Highlighted
Absent Member.. Absent Member..
Absent Member..
5949 views

Error -27796: Failed to connect to server "XXXXXXXXXX.XXXX:443": [10060] Connection timed out "

Action.c(28): web_url("XXXX.XXXXX.com") started [MsgId: MMSG-26355]
Action.c(28): t=779ms: Connecting [0] to host XX.XX.XX.XX:443 [MsgId: MMSG-26000]
Action.c(28): Error -27796: Failed to connect to server "XXXX.XXXXX.XXXX:443": [10060] Connection timed out [MsgId: MERR-27796]
Action.c(28): t=21788ms: Closed connection [0] to XXXXX.XXXXX.com:443 after completing 0 requests [MsgId: MMSG-26000]

 

  when I record the script everything works fine but wile reply i have faced this error.

 

  I have tried to give the below line in the begining of the script but still its fails.

 

  web_set_sockets_option("SSL_VERSION", "TLS");

 

  I have increaed the timed and connection setting in runtime settings and preference but stills its fails.

 

  Version: Vugen 11.52

 

  Any suggestion.

 

  Thanks,

  Varun C

 

Tags (2)
0 Likes
8 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Error -27796: Failed to connect to server "XXXXXXXXXX.XXXX:443": [10060] Connection ti

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Error -27796: Failed to connect to server "XXXXXXXXXX.XXXX:443": [10060] Connection ti

Hi Hamed

 

Instead of this link, if we get some description or detailed explaination it will be helpful.

 

Thanks

Asif

 

0 Likes
Highlighted
Super Contributor.
Super Contributor.

Re: Error -27796: Failed to connect to server "XXXXXXXXXX.XXXX:443": [10060] Connection ti

Modify the connection timeout under RTS as follows:

RTS -->Internet Protocol --> Preferences --> Options --> HTTP-request connect timeout (sec) currently set to 900 increse to a higher value.

To set Connect time-out value to greater that 1000 , use the following at the beginning of the Action section: web_set_timeout(CONNECT, "1500");

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Error -27796: Failed to connect to server "XXXXXXXXXX.XXXX:443": [10060] Connection ti

its stating I dnt have permission for reading the article

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Error -27796: Failed to connect to server "XXXXXXXXXX.XXXX:443": [10060] Connection ti

I have increased the timeout to 1000 and used the web_set_timeout(CONNECT, "1500"); before the script starts.

 

Stills the result remains same.

 

When I searched in google and i got information about ssl certificate issue.

 

Anybody come across this scenerio.

 

Thanks,

C Varun

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Error -27796: Failed to connect to server "XXXXXXXXXX.XXXX:443": [10060] Connection ti

Try to change the proxy configuration on RTS, obtaining the proxy settings from the default browser. And check the  maximum number of connections that can be established at a given time.

0 Likes
Highlighted
Trusted Contributor.
Trusted Contributor.

Re: Error -27796: Failed to connect to server "XXXXXXXXXX.XXXX:443": [10060] Connection ti

Hi,

Have you found solution on this? as i facing the same issue.

0 Likes
Highlighted
Respected Contributor.
Respected Contributor.

Re: Error -27796: Failed to connect to server "XXXXXXXXXX.XXXX:443": [10060] Connection ti

Hi,

Same issue for me. It's working fine on the Browser but when I try to record it with vugen 12.55, it's take very long to show the page. 


Regards,

Mike

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.