Highlighted
Established Member..
Established Member..
10112 views

Error: CCI security error: You are running under secure mode

Jump to solution

Hello HP,

 

 Controller& LG’s Version: 11.50 (SP2 installed)

Protocol: FLEX



(Controller & LG’s)OS : Windows server 2008 R2 standard

This is a roadblock for me.

 

I am getting the below error only for 2 LG's.

 

Error: CCI security error: You are running under secure mode and the function ci_load_dll is not allowed in this mode.

 

While I am running the test   with 4 LG's , I am getting the above error for 2 LG's only.

 

When I looked the error thrown LG"s running as Load Runner Process ,even though I changed it back to as Load Runner Agent Service, still shows Load Runner Agent process.

 

One of other Team used the LG's for to run the test which is Citrix application.

 

They have installed Citrix Agent on all LG's.

 

Thanks,

Rajani

0 Likes
1 Solution

Accepted Solutions
Highlighted
Established Member..
Established Member..

Re: Error: CCI security error: You are running under secure mode

Jump to solution

 I found the root cause and fixed it!

View solution in original post

0 Likes
8 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Error: CCI security error: You are running under secure mode

Jump to solution

Hi Rajani,

 

Please follow the instructions in the following knowledge document:

Error: "-19886: CCI security error:You are running under secure mode and the function <function_name> is not allowed in this mode."

http://support.openview.hp.com/selfsolve/document/KM173048

 

Please let us know if it solved the problem.

 

Kind regards,

 

HPE Support
If you haven’t tried it yet, come and join us in our entitled forums at Support Customer Forums

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution and give Kudos to the author for their assistance.
0 Likes
Highlighted
Established Member..
Established Member..

Re: Error: CCI security error: You are running under secure mode

Jump to solution

 I found the root cause and fixed it!

View solution in original post

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Error: CCI security error: You are running under secure mode

Jump to solution

Hi,

 

Can you please share what was the root cause and how you fixed it so that other mambers in the forum can benfit from it?  

 

Thank you.

 

Kind regards,

HPE Support
If you haven’t tried it yet, come and join us in our entitled forums at Support Customer Forums

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution and give Kudos to the author for their assistance.
0 Likes
Highlighted
Established Member..
Established Member..

Re: Error: CCI security error: You are running under secure mode

Jump to solution

Firewall  was enabled for those 2 LG's, and  disabled it.

 

 

Thanks,

Raj

Tags (1)
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Error: CCI security error: You are running under secure mode

Jump to solution

Is there any more info for this? I am getting the same error with LoadRunner / Load Generator 11.52 though the prohibited function is gethostbyname. The HP solution of the .asl file does not work for me because the location and the asl files mentioned do not exist on my load generators.

 

For disabling firewall are there any alternatives or specific holes that can be poked into the firewall instead of disabling. The load generators and controller are all in the same VLAN and my corporate IT tells me that all ports and everything should be open between them. Windows Firewall is not running on these machines.

 

Is there anything else I can check?

 

Thanks,

Scott

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Error: CCI security error: You are running under secure mode

Jump to solution

If you are using Performance Center, try using "-cancel_security_mode" under edit command line next to edit runtime setting, this will disable the security mode and LG would have no problem executing script with these functions.

Highlighted
Contributor.. Contributor..
Contributor..

Re: Error: CCI security error: You are running under secure mode

Jump to solution
Hi,

I am also facing same issue. I have tried with enable firewall and disabled the firewall but both cases I'm getting same error. We also defined inbound&outbound rules in firewall.
We are using load runner 12.53 controller.
Could you please help me here.
Thanks,
Gopal
0 Likes
Highlighted
Super Contributor.
Super Contributor.

Re: Error: CCI security error: You are running under secure mode

Jump to solution

Hi Gopal,

Disabled the Firewall and restartng the load runner agent service worked for me in sloving the issue, you can try the same.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.