Highlighted
Valued Contributor.. Valued Contributor..
Valued Contributor..
339 views

Error: Detected OUT Event (event name="wplus_http_wsock_request_ex")

Hi to all,

I have a problem with the registration with LoadRunner 12.02 with SAP-Web Protocol. (And olso with the Web HTTP/HTML)

 At the end of the registration some HTTP- Events aren't record, in the Recording Log I have found an error like this:

"[Vugen Inspector Error ( ec4:25d8)] Detected OUT Event (event name="wplus_http_wsock_request_ex") with no matching IN Event"

And in the Recordered Events I have found this event:

[Op#: 12]------------------------------------------------------------------------------
Api Event (1760) : Id=HTTP Proc=0ec4:80002001 Start=272175921 End=272175937 Duration=16 msec
Operation Name : wplus_http_wsock_request_ex
Argument# 1 IN : [session_id] = 2
Argument# 2 IN : [http_id] = 1
Argument# 3 IN : [ipaddress] = 127.0.0.1 (0100007f)
Argument# 4 IN : [portnum] = 8888
Argument# 5 IN : [urladdress] = ""
Argument# 6 IN : [hdr_buffer] = ->Array[0:242]{ "CONNECT XXXXXX.pgc.local:443 HTTP/1.1\r\n"
"Host: XXXXXX.pgc.local:443\r\n"
"Proxy-Connection: keep-alive\r\n"
"User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.143 Safari/537.36\r\n"
"\r\n"
"" }
Argument# 6 OUT : [hdr_buffer] = ->Array[0:107]{ "HTTP/1.1 200 Connection Established\r\n"
"FiddlerGateway: Direct\r\n"
"StartTime: 15:05:24.160\r\n"
"Connection: close\r\n"
"\r\n"
"" }
Argument# 7 IN : [hdr_buflen] = ->242
Argument# 7 OUT : [hdr_buflen] = ->107
Argument# 8 IN : [body_buffer] = ->Array[0:0]{ NULL }
Argument# 8 OUT : [body_buffer] = ->Array[0:0]{ NULL }
Argument# 9 IN : [body_buflen] = ->0
Argument# 9 OUT : [body_buflen] = ->0
Argument# 10 IN : [body_filename] = ->Array[0:0]{ NULL }
Argument# 10 OUT : [body_filename] = ->Array[0:0]{ NULL }
Argument# 11 IN : [body_filelen] = ->0
Argument# 11 OUT : [body_filelen] = ->0
Argument# 12 IN : [flags] = ->0
Argument# 12 OUT : [flags] = ->0
Argument# 13 IN : [sourceipaddress] = 10.121.200.1 (01c8790a)
Argument# 14 IN : [sourceportnum] = 9933
Return Value : (void)

Someone have any ideas?

 

Thank you in advance.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.