Highlighted
Established Member..
Established Member..
441 views

Error using url

We are using url http://10.87.149.104:9121/CampaignSubProfile, but when we use Web HTML protocal request is not getting captured and checking in generation log it is giving error as

 

********************************************************************************************

 

$$$$$ Request Header For Transaction With Id 0 Ended $$$$$$

****** Response Header For Transaction With Id 0 ******
HTTP/1.1 500 Error
TransactionID:
Content-Type: text/xml
X-Backside-Transport: FAIL FAIL
Connection: close


$$$$$$ Response Header For Transaction With Id 0 Ended $$$$$$

****** Response Body For Transaction With Id 0 ******
<?xml version="1.0" encoding="UTF-8"?>
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:cam="http://eai.vodafone.com/campaignSubProfile"><soapenv:Header/><soapenv:Body><cam:CampaignSubProfileResponse><cam:MetaInfo><cam:ConsumerReqInfo><cam:circleId/><cam:serviceName/><cam:channelName/><cam:segment/><cam:key/></cam:ConsumerReqInfo><cam:StatusInfo><cam:errorCode>VEAI101130024E</cam:errorCode><cam:errorStatus>1</cam:errorStatus><cam:errorCategory>ESB Internal Error</cam:errorCategory><cam:errorDesc>0x01130024 Request did not match allowed-feature list</cam:errorDesc></cam:StatusInfo></cam:MetaInfo><cam:SRVcampaignSubProfile><cam:MSISDN/></cam:SRVcampaignSubProfile></cam:CampaignSubProfileResponse></soapenv:Body></soapenv:Envelope>
$$$$$$ Response Body For Transaction With Id 0 Ended $$$$$$

****** Start Log Message ******

Start Frames Hierarchy Tree Dump
The Node has no URL
End Frames Hierarchy Tree Dump

$$$$$$ End Log Message $$$$$$

***************************************************************************************************************

 

What could be possbile reasons for this?

 

Any ideas please suggest..

 

Below is the output of url

 

0 Likes
1 Reply
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Error using url

Hi,

By default, LoadRunner doesn't create steps for request with HTTP errors (404 or 500 as in your case).

To do that, you can  try workaround by adding  new registry key.

 

Please, create GenerateApiFuncForCustomHttpStatus STRING entry with value 500 under 

HKEY_CURRENT_USER\Software\Mercury Interactive\Networking\Multi Settings\QTWeb\Recording node.

 

In case you need several codes just use semicolon (;) as delimiter (like 500;501;505).

Hope it will help.

Thanks,

Leonid.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.