Highlighted
Honored Contributor.. Honored Contributor..
Honored Contributor..
2976 views

Errors from the NV module in both VuGen and Controller (LR 12.55 Community)

Hi,

I am currently fiddling with the latest and greatest version of the LoadRunner Community edition (12.55) and have successfully installed the complete package on my local machine (Windows 10, x64). No alterations was done during the installation wizard.

Scripts and scenarios are running all fine, but I am really struggling with the connectivity towards the Network Virtualization module.

These are the two scenarios I have met where the integration seems to be faulty:

After a successful run in VuGen I expect the NV Analytics report to be generated. I am always met by this error warning/error message: "NV Analytics: Failed to analyze the script. Contact support for assistance." See the attached image as well.

After a successful run in the Controller, I am always met by these three error messages when the report generation mechanism is conducted - and yes, all steps and requirements needed to create a NV Report are met:

  • Unable to format message id [-206064]
  • Error: Failed to generated NV report for group: espresso_nv1. Error:
  • Network Virtualization Analytics report generation failed.

See the attached image for these errors as well.

So, could someone please elaborate on these issues and/or test if this works in your environment?

Thanks in advance!

0 Likes
4 Replies
Highlighted
Honored Contributor.. Honored Contributor..
Honored Contributor..

Re: Errors from the NV module in both VuGen and Controller (LR 12.55 Community)

Anyone? Are there any logs I might provide you with?

Thanks in advance!

0 Likes
Highlighted
Contributor.
Contributor.

Re: Errors from the NV module in both VuGen and Controller (LR 12.55 Community)

Hi

 As NV Insights report was failed in VuGen too I would suggest we start diagnose the failure on VuGen first:

  1. Please attach NV logs folder (C:\Program Files\HPE\NV\logs)
  2. Is there a warnings in VuGen output dialog? If there are can saved them to a txt file and attach it.
  3. Please confirm NV Active adapter is the one network traffic goes through: search for “NV agent” >pin it to taskbar>right click on icon and click on “Active adapter setting…”>verify the NIC/IP is the desired one.
  4. Please attach “shunra.shunra” and “replay.har” located in script folder (default: C:\Users\Administrator\Documents\VuGen\Scripts\<script folder>)
  5. If you recorded a script of an external website and can share with us – it can be helpful. If not , which protocol you have recorded with?
  6. Please attach NV installation logs located in C:\Temp\NV_Logs

Folders/files might be  too large to attached if that the case please contact me directly (omer.kenan@microfocus.com ) and I’ll give you  FTP details to upload them.

 

Best Regards,

Omer Kenan

Network Virtualization, Customer Facing R&D.

0 Likes
Highlighted
Honored Contributor.. Honored Contributor..
Honored Contributor..

Re: Errors from the NV module in both VuGen and Controller (LR 12.55 Community)

Hi Omer and thank you so much for your reply! Hopefully we might find a solution to this really annoying problem. 🙂

Please attach NV logs folder (C:\Program Files\HPE\NV\logs)

See the attached zip file.

Is there a warnings in VuGen output dialog? If there are can saved them to a txt file and attach it.

No warnings in the output dialog. The problem occurs regardless of which site I am trying to record on.

Please confirm NV Active adapter is the one network traffic goes through: search for “NV agent” >pin it to taskbar>right click on icon and click on “Active adapter setting…”>verify the NIC/IP is the desired one.

Confirmed. 🙂

Please attach “shunra.shunra” and “replay.har” located in script folder (default: C:\Users\Administrator\Documents\VuGen\Scripts\<script folder>)

See the attached zip file.

If you recorded a script of an external website and can share with us – it can be helpful. If not , which protocol you have recorded with?

The recording is conducted on the Web - HTTP/HTML protocol. The problem occurs regardless of site. 

Please attach NV installation logs located in C:\Temp\NV_Logs

See the attached zip file.

Again, really appreciate your help!

0 Likes
Highlighted
Contributor.
Contributor.

Re: Errors from the NV module in both VuGen and Controller (LR 12.55 Community)

 

Hi

I have failed  to generate by rest API a NV insights report using  your  HAR and shunra file.

I get same error as you had.

However I could run similar script as you had recorded (i took URL from your HAR) and generated NV insights successfully.

Please contact me privately so we can have a WebEx session.

Best Regards,

Omer.

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.