Highlighted
Super Contributor.
Super Contributor.
348 views

Failed to connect to server "XXXXXX.com:443": [10060] Connection timed out

Hello All

I am able to access the application manually and able to record a Web(HTTP/HTML) script using Vugen12.60 but while replying a script, getting “Connection timed out” error.
Environment: Vugen 12.60 IE11,

RTS: No Proxy 

Tried below options but no luck.

Increased HTTP Request Connect Timeout ("999"), HTTP Request ReceiveTimeout ("999") and Keep Alive Timouts

Also, Added web_set_sockets_option("SSL_VERSION", "2&3");
Replied script with “Winnet reply instead of Sockets”, error: "HttpSendRequest" failed, Windows error code=12029 (cannot connect) and retry limit (0) exceeded for URL=”
Any suggestion would be highly appreciated.

Thanks,

Manoj Thota

@AvniLior , @h2o_2 @Shlomi Nissim 

0 Likes
7 Replies
Highlighted
Respected Contributor.. Respected Contributor..
Respected Contributor..

@ManojThota1 Jadu bhai here 🙂 lots of reasons could be contributing to such errors. you have tried some of them already. Few more if you want to try out: 1) Change replay browser to Chrome/Firefox, 2) Try SSL Version as TLS1.2 3) Increase retry limit 4) Disable extended log

Good luck.

0 Likes
Highlighted
Super Contributor.
Super Contributor.

Thanks for your response Jadu Bhai....

We have found the root cause of this issue, by enabling the advance trace
and found that when we are hitting to the direct webserver IP we are
getting failled to connect server error, but when we are hitting the F5
load balancer host it is giving the proper response.... So project team
found that some miss configuration in F5 load balancer level..

##-
-##

Thanks,
Manoj Thota
0 Likes
Highlighted
Super Contributor.
Super Contributor.

Thanks for your response Jadu Bhai....

We have found the root cause of this issue, by enabling the advance trace in LR and found that when we are hitting to the direct webserver IP we are getting failled to connect server error, but when we are hitting the F5 load balancer host it is giving the proper response.... So project team found that some miss configuration in F5 load balancer level and they have fixed by raising the service now ticket with F5 team..

Thanks,
Manoj Thota
0 Likes
Highlighted
Respected Contributor.. Respected Contributor..
Respected Contributor..

That's strange because, if manually you are able to access and also record by skipping the F5, I wonder why it wouldn't work while replaying.
0 Likes
Highlighted
Super Contributor.
Super Contributor.

Yes manually i am able to access but it is taking to much of time almost 3 to 4 minutes to connect to the server, but while replaying the script load runner request it is not waiting that much of time to connect even after increasing the http server connect, receive connect keep alive and even increasing the retry limit.....

Thanks
Manoj Thota
0 Likes
Highlighted
Respected Contributor.. Respected Contributor..
Respected Contributor..

Ahhh that makes sense now. Good you got it working.
0 Likes
Highlighted
Super Contributor.
Super Contributor.

But now after they configure the proper settings in F5 load balancer level that request is responding within a fraction of seconds (manually and even in LR requests

Thanks
Manoj Thota
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.