Highlighted
Frequent Contributor.
Frequent Contributor.
360 views

Failed to record authentication window in truclient script

Jump to solution

hi

I am working  on a turclient script in loadrunner 12.63

I have a step in my script where I have to import a file from windows explorer and then click on import. While doing things manually everything is working well. Manually when I browse the file and click on import, a authentication window comes up, where I have to put credentials to successfully import the file.

but while recording the script, I am not able to record the authentication window, as it doesn't show up in interactive mode.

so when I am clicking on import after browsing the file and clicking on import... the step just keep on processing.

I am working with IE

anyone having any idea about how to resolve this?

0 Likes
1 Solution

Accepted Solutions
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: Failed to record authentication window in truclient script

Jump to solution

Hi Narender,

sometimes, due to NTLM or particular browser settings, LoadRunner can't automatically record Windows authentication pop-up. 

You can do it manually on TruClient: in the "Toolbox", select a "Generic Browser Action" and drag it on the interested step on the navigation, then expand "Step" and select "Action -> Dialog -> Authenticate". At this point, you can write the credential informations (username, password, domain). 

Tell me if this suggestion can help you, 

Lorenzo

View solution in original post

6 Replies
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: Failed to record authentication window in truclient script

Jump to solution

Hi Narender,

sometimes, due to NTLM or particular browser settings, LoadRunner can't automatically record Windows authentication pop-up. 

You can do it manually on TruClient: in the "Toolbox", select a "Generic Browser Action" and drag it on the interested step on the navigation, then expand "Step" and select "Action -> Dialog -> Authenticate". At this point, you can write the credential informations (username, password, domain). 

Tell me if this suggestion can help you, 

Lorenzo

View solution in original post

Highlighted
Frequent Contributor.
Frequent Contributor.

Re: Failed to record authentication window in truclient script

Jump to solution
hi lb1
thanks for your reply, I have already tried this method, but the thing is if I do that step manually, no authentication popup comes, but in interactive mode, if i stop the script just before this step, and do that step manually than it is coming.....
0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

Re: Failed to record authentication window in truclient script

Jump to solution
0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

Re: Failed to record authentication window in truclient script

Jump to solution
Hi lb1,
thanks for help
but I have tried this method, and it is not working.
I am trying to import a SOV file, maybe there I am doing something wrong.
can you put some light on how to import it through file explorer. I think while recording the script is not saving the full path. it is saving it as V:\\.fakepath... something.
0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: Failed to record authentication window in truclient script

Jump to solution

Hi Narender, 

if the authentication dialog is a conseguence of a file upload, then maybe (as you said) the problem is on the file import. How do you make this action? I can suggest you to load the file from "Extra Files" step on your script (right click on "Extra Files -> Add new file to script"); then drag a JavaScript step as the step of the upload and wrote something like that, 

    TC.scriptDir + \fileName.ext";  

Lorenzo

0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

Re: Failed to record authentication window in truclient script

Jump to solution
hi lb1
thanks for all your time and efforts
as earlier I implemented this, it was failing but I tried it again and this time it worked.
thanks
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.