Highlighted
New Member.
328 views

How to block windows security authentication popup in true client IE mode

Hi Team,

While replaying the trueclient script in developer mode of IE ,once we are trying to invoke the URL the windows security authentication pop up is getting displayed.Which doesnt came during recording.

Please suggest the necessary steps to stop this.

Note:-When we are trying to invoke the URL in standalone IE not through LR this pop up is not getting displayed.

Thanks.

 

 

 

 

0 Likes
1 Reply
Highlighted
Trusted Contributor.
Trusted Contributor.

Re: How to block windows security authentication popup in true client IE mode

Hi girimcet, 

Thanks for your feedback. We're aware of this issue. Please try the solution below: 

Try to Enable the negotiate method for authentication:

If your application server supports only the negotiate method for authentication (the HTTP response is with "HTTP/1.1 401 Unauthorized" and "WWW-Authenticate: Negotiate"), you must enable the negotiate option. To do so:

  1. Open the registry setting HKEY_CURRENT_USER\Software\Hewlett-Packard\TruClient\TruClientIE\TCWindows\CurrentVersion\Internet Settings.
  2. Change the value of the EnableNegotiateregistry key from "0" to "1".

If it does not work for you, feel free to reach us again. We're here to support. 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.