Highlighted
New Member.
2275 views

How to solve SSL error in HPP step

Hi,

I am facing http send request failed issue while am executing performance test in performance center. Earlier the HPP login step was SSL version as TLS but now they are changed into SSL as TLS1.0.

Accordingly I was updated all the test scripts with new TLS but unfortunately its getting failed and have got error message as ssl protocol error when attempting to connect with host.

To avoid the above issue I was checked the wininet replay instead of sockets options in runtime settings and have executed it but again am getting the error now. Please find the below error message details,

 

  1. "HttpSendRequest" failed, Windows error code=12029 (cannot connect) and retry limit (0) exceeded for URL=https://cfstg.passport.hpe.com/login.fcc
  2. "HttpSendRequest" failed, Windows error code=12029 (cannot connect) and retry limit (0) exceeded for URL="https://cfstg.passport.hpe.com/hppcf/login.do?hpappid=202392_OSP_ITG_HPE&TYPE=33554433&REALMOID=06-000eaa58-fe8d-1791-9706-60d210c3d01d&GUID=&SMAUTHREASON=0&METHOD=GET&SMAGENTNAME=$SM$D8GWnhx71FaANVo4AcqNLFk5igi%2fAWUxcuece4Yg4%2frp4TX9rVCQCtY3ai4BBkPs&TARGET=$SM$https%3a%2f%2fsso-itg%2eext%2ehpe%2ecom%2fgroup%2fsoftwaresupport%2fmySupport"

 

Please let me know if you have any questions on this and please help me to troubleshoot this issue.

 

Tags (1)
0 Likes
2 Replies
Highlighted
Frequent Contributor.
Frequent Contributor.

Re: How to solve SSL error in HPP step

 

Hello,

Please add:

web_set_sockets_option("SSL_VERSION", "TLS1.2");

at beginning of your login step. I just recorded the page with LR12.53, the web_set_sockets_option("SSL_VERSION", "TLS1.2"); was automatically added and replay passed with no error. 

Regards,

Bingle

Highlighted
New Member.

Re: How to solve SSL error in HPP step

Hi Bingle,

Thanks for your reply.

I was tried this code web_set_sockets_option("SSL_VERSION","TLS1.2");  in top of my script and it was ran successfully of one transaction. But when its moving for login step, transaction got failed so that was used the same above code into the login step also. But there is no positive results from that.

Could you please check attached file for refernce and please help to solve this issue.

I am using to replay LR 12.50 version.

Regards,

Sakthi

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.