Highlighted
Valued Contributor.. Valued Contributor..
Valued Contributor..
261 views

How to solve Vugen HTTP/HTML recording events but response of capture is 0 bytes in snapshot.

Jump to solution

I am using windows 10 and I am able to record/capture events successfully but when I look at snapshot of those events the size is 0 byte and no response data captured. any idea how to solve this one?

0 Likes
1 Solution

Accepted Solutions
Highlighted
Valued Contributor.. Valued Contributor..
Valued Contributor..

Re: How to solve Vugen HTTP/HTML recording events but response of capture is 0 bytes in snapshot.

Jump to solution

I have uninstall completely and reinstall the LoadRunner and it resolved the above issue.

 

View solution in original post

0 Likes
3 Replies
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: How to solve Vugen HTTP/HTML recording events but response of capture is 0 bytes in snapshot.

Jump to solution

Hi,

have you tried to set the "Snapshot" arguments on the function? Is your case a manual web_custom_request() or an automatic generation of functions due a recording phase?

web_url("Some Website",

"URL=http://www.somewebsite.com",

"RecContentType=text/html",

"Snapshot=t1.inf",

"Mode=HTTP",

LAST);

In some cases, LoadRunner can't see the "HTTP View", but you can see the "Raw Data" returned by the server. Can you tried, also, to set the "Generate snapshots on error" option from Runtime Settings? 

Lorenzo

0 Likes
Highlighted
Valued Contributor.. Valued Contributor..
Valued Contributor..

Re: How to solve Vugen HTTP/HTML recording events but response of capture is 0 bytes in snapshot.

Jump to solution

Thanks Lorenzo,

I am trying to speed up my process of correlation and looking deep into it. it do not have baseline data to compare so trying to find solution to how to resolve this one. 

[t7]
FileName1=t7.html
URL1=https:https://somewebsite.com/xx/...Retrieve
Total=2
ContentType=
SnapshotXmlFile=snapshot_7.xml
RequestHeaderFile=t7_RequestHeader.txt
RequestBodyFile=NONE
FileName2=t7_obrar.html
URL2=https:https://somewebsite.com/xx/...
[ProtocolInfo]
ProtocolId=QTWeb

the t7.html and t7_obrar.html suppose to have data return by server but it's size is 0.

on replay is same also some time it captures snapshot. that makes correlation hard.

I am enabling and extended log and capturing the data and generating  correlation but that process is time consuming. in widows 7 it  was working fine so wondering if any one has solution on how to resolve this one.  

0 Likes
Highlighted
Valued Contributor.. Valued Contributor..
Valued Contributor..

Re: How to solve Vugen HTTP/HTML recording events but response of capture is 0 bytes in snapshot.

Jump to solution

I have uninstall completely and reinstall the LoadRunner and it resolved the above issue.

 

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.